summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/netbeans-apisupport/netbeans-apisupport-9999_p20120325.ebuild')
-rw-r--r--dev-java/netbeans-apisupport/netbeans-apisupport-9999_p20120325.ebuild107
1 files changed, 0 insertions, 107 deletions
diff --git a/dev-java/netbeans-apisupport/netbeans-apisupport-9999_p20120325.ebuild b/dev-java/netbeans-apisupport/netbeans-apisupport-9999_p20120325.ebuild
deleted file mode 100644
index e0ee41205..000000000
--- a/dev-java/netbeans-apisupport/netbeans-apisupport-9999_p20120325.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-WANT_ANT_TASKS="ant-nodeps"
-inherit eutils java-pkg-2 java-ant-2
-
-DESCRIPTION="Netbeans API Support Cluster"
-HOMEPAGE="http://netbeans.org/projects/apisupport"
-SLOT="9999"
-SOURCE_URL="http://bits.netbeans.org/download/trunk/nightly/2012-03-25_04-01-18/zip/netbeans-trunk-nightly-201203250401-src.zip"
-SRC_URI="${SOURCE_URL}
- http://dev.gentoo.org/~fordfrog/distfiles/netbeans-9999-r2-build.xml.patch.bz2"
-LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-S="${WORKDIR}"
-
-CDEPEND="~dev-java/netbeans-harness-${PV}
- ~dev-java/netbeans-ide-${PV}
- ~dev-java/netbeans-java-${PV}
- ~dev-java/netbeans-platform-${PV}"
-DEPEND="virtual/jdk:1.6
- app-arch/unzip
- ${CDEPEND}
- dev-java/javahelp:0"
-RDEPEND=">=virtual/jdk-1.6
- ${CDEPEND}"
-
-INSTALL_DIR="/usr/share/${PN}-${SLOT}"
-
-EANT_BUILD_XML="nbbuild/build.xml"
-EANT_BUILD_TARGET="rebuild-cluster"
-EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.apisupport -Dext.binaries.downloaded=true"
-EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
-JAVA_PKG_BSFIX="off"
-
-src_unpack() {
- unpack $(basename ${SOURCE_URL})
-
- einfo "Deleting bundled jars..."
- find -name "*.jar" -type f -delete
-
- unpack netbeans-9999-r2-build.xml.patch.bz2
-}
-
-src_prepare() {
- einfo "Deleting bundled class files..."
- find -name "*.class" -type f | xargs rm -vf
-
- epatch netbeans-9999-r2-build.xml.patch
-
- # Support for custom patches
- if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
- local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
-
- if [ -n "${files}" ] ; then
- einfo "Applying custom patches:"
-
- for file in ${files} ; do
- epatch "${file}"
- done
- fi
- fi
-
- einfo "Symlinking external libraries..."
- java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
-
- einfo "Linking in other clusters..."
- mkdir "${S}"/nbbuild/netbeans || die
- pushd "${S}"/nbbuild/netbeans >/dev/null || die
-
- ln -s /usr/share/netbeans-harness-${SLOT} harness || die
- cat /usr/share/netbeans-harness-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.harness.built
-
- ln -s /usr/share/netbeans-ide-${SLOT} ide || die
- cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.ide.built
-
- ln -s /usr/share/netbeans-java-${SLOT} java || die
- cat /usr/share/netbeans-java-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.java.built
-
- ln -s /usr/share/netbeans-platform-${SLOT} platform || die
- cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
- touch nb.cluster.platform.built
-
- popd >/dev/null || die
-
- java-pkg-2_src_prepare
-}
-
-src_install() {
- pushd nbbuild/netbeans/apisupport >/dev/null || die
-
- insinto ${INSTALL_DIR}
-
- grep -E "/apisupport$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
-
- doins -r *
-
- popd >/dev/null || die
-
- dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/apisupport
-}