summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2010-04-04 18:12:25 +0200
committerRomain Perier <mrpouet@gentoo.org>2010-04-04 18:12:25 +0200
commit15a4b7570726d35325ad31f003d225d1efa66a83 (patch)
tree1987b109b14c9a349763dd2230318856519d994d
parentx11-libs/libnotify: (diff)
downloadmrpouet-15a4b7570726d35325ad31f003d225d1efa66a83.tar.gz
mrpouet-15a4b7570726d35325ad31f003d225d1efa66a83.tar.bz2
mrpouet-15a4b7570726d35325ad31f003d225d1efa66a83.zip
gnome-extra/indicator-application:
* New ebuild
-rw-r--r--gnome-extra/indicator-application/Manifest3
-rw-r--r--gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch67
-rw-r--r--gnome-extra/indicator-application/indicator-application-0.0.19.ebuild59
3 files changed, 129 insertions, 0 deletions
diff --git a/gnome-extra/indicator-application/Manifest b/gnome-extra/indicator-application/Manifest
new file mode 100644
index 0000000..dd27238
--- /dev/null
+++ b/gnome-extra/indicator-application/Manifest
@@ -0,0 +1,3 @@
+AUX indicator-application-0.0.19-bindings-automagic.patch 1896 RMD160 c76541c801748087f22cdafc354c5408fff4bab6 SHA1 d96b1de61a1208a3edb48e7ed07825b2d2a19bf9 SHA256 58e399fb5dbe2ecee03e36245de5c5c02b35c4a523995a0de7a74eadd7833c09
+DIST indicator-application-0.0.19.tar.gz 460639 RMD160 16e92ec421996c35a24eac7375c64fc564c7149d SHA1 e8e4f52aeee63e71bd4a56b928388e7a0ed0510d SHA256 d4279a7fa4f9c484ad7e6db4e5af43f00a6a9a78c979a6151835db29982df101
+EBUILD indicator-application-0.0.19.ebuild 1265 RMD160 6dbcbe2970bfd6ae64086f775966bb26846115b6 SHA1 93f55e0ec2c1544e9e021b56df497db276040160 SHA256 665fd261ca6444aa7b12c5b1b44fcebba3ed7dbbcb906c0fa5a1df1ed0a50d7f
diff --git a/gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch b/gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch
new file mode 100644
index 0000000..f00cbd0
--- /dev/null
+++ b/gnome-extra/indicator-application/files/indicator-application-0.0.19-bindings-automagic.patch
@@ -0,0 +1,67 @@
+From: Romain Perier <mrpouet@gentoo.org>
+Date: Sun, 4 Apr 2010 17:39:50 +0200
+Subject: Do not build bindings as automagic supports, they should be optionnal
+
+---
+ bindings/Makefile.am | 12 +++++++++---
+ configure.ac | 8 ++++++++
+ 2 files changed, 17 insertions(+), 3 deletions(-)
+
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
+@@ -1,3 +1,9 @@
+-SUBDIRS = \
+- mono \
+- python
++SUBDIRS=
++
++if BUILD_MONO
++SUBDIRS += mono
++endif
++
++if BUILD_PYTHON
++SUBDIRS += python
++endif
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,7 +55,9 @@ AC_SUBST(INDICATOR_LIBS)
+ ###########################
+ # Check for Mono support
+ ###########################
++AC_ARG_ENABLE([mono], [AC_HELP_STRING([--enable-mono], [Build Mono binding])], enable_mono="$enableval", enable_mono="auto")
+
++if test "x$enable_mono" != "xno"; then
+ MONO_REQUIRED_VERSION=1.0
+ PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= $MONO_REQUIRED_VERSION, has_mono=true, has_mono=false)
+
+@@ -109,7 +111,9 @@ AC_SUBST(GAPI_FIXUP)
+
+ PKG_CHECK_MODULES(NUNIT, nunit >= 2.4.7)
+ AC_SUBST(NUNIT_LIBS)
++fi
+
++AM_CONDITIONAL([BUILD_MONO], [test "x$enable_mono" != "xno"])
+ ###########################
+ # Check to see if we're local
+ ###########################
+@@ -145,7 +149,9 @@ AC_SUBST(DBUSSERVICEDIR)
+ ###########################
+ # Python
+ ###########################
++AC_ARG_ENABLE([python], [AC_HELP_STRING([--enable-python], [Build Python binding])], enable_python="$enableval", enable_python="auto")
+
++if test "x$enable_python" != "xno"; then
+ PYGTK_REQUIRED=2.14.0
+ PYGOBJECT_REQUIRED=0.22
+
+@@ -170,7 +176,9 @@ AC_MSG_CHECKING(for pygtk codegen)
+ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+ AC_SUBST(PYGTK_CODEGEN)
+ AC_MSG_RESULT($PYGTK_CODEGEN)
++fi
+
++AM_CONDITIONAL([BUILD_PYTHON], [test "x$enable_python" != "xno"])
+ ###########################
+ # Files
+ ###########################
+
diff --git a/gnome-extra/indicator-application/indicator-application-0.0.19.ebuild b/gnome-extra/indicator-application/indicator-application-0.0.19.ebuild
new file mode 100644
index 0000000..cf0f4dc
--- /dev/null
+++ b/gnome-extra/indicator-application/indicator-application-0.0.19.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+GCONF_DEBUG="no"
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A library and indicator to take menus from applications and place them in the panel. "
+HOMEPAGE="https://launchpad.net/indicator-application"
+SRC_URI="http://launchpad.net/${PN}/0.1/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2.1 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples mono python"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libindicator-0.3.5
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/libdbusmenu-0.2.2[gtk]
+ mono? (
+ dev-lang/mono
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/glib-sharp-2.12.1
+ )
+ python? ( >=dev-python/pygtk-2.14.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/gtk-doc"
+
+DOCS="ChangeLog"
+
+pkg_setup() {
+ G2CONF="--disable-dependency-tracking
+ $(use_enable mono)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Don't build Python and Mono bindings as default (they should be optionnal)
+ epatch "${FILESDIR}"/${P}-bindings-automagic.patch
+
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc example/* || die "dodoc failed"
+ fi
+}