summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Business-EDI/Business-EDI-0.05.ebuild')
-rw-r--r--dev-perl/Business-EDI/Business-EDI-0.05.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Business-EDI/Business-EDI-0.05.ebuild b/dev-perl/Business-EDI/Business-EDI-0.05.ebuild
new file mode 100644
index 0000000..c13870e
--- /dev/null
+++ b/dev-perl/Business-EDI/Business-EDI-0.05.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# This ebuild generated by g-cpan 0.16.4
+
+EAPI="2"
+
+MODULE_AUTHOR="JOEATZ"
+MODULE_A_EXT="tgz"
+# This is crazy
+S="${WORKDIR}/atz-${PN}-327e01f"
+
+inherit perl-module
+
+DESCRIPTION="Objects for U.N. EDI data"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-perl/File-Find-Rule-0.32
+ >=dev-perl/JSON-XS-2.3
+ >=dev-perl/Exporter-Easy-0.16
+ dev-perl/List-MoreUtils
+ >=dev-perl/UNIVERSAL-require-0.13
+ dev-lang/perl"
+
+src_unpack() {
+ perl-module_src_unpack
+ # Upstream has really weird naming
+ [ -d "${S}" ] || \
+ die "Upstream has changed the directory again, please file a bug"
+}