summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gengetopt/gengetopt-2.22.1.ebuild')
-rw-r--r--dev-util/gengetopt/gengetopt-2.22.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/gengetopt/gengetopt-2.22.1.ebuild b/dev-util/gengetopt/gengetopt-2.22.1.ebuild
new file mode 100644
index 0000000..5647613
--- /dev/null
+++ b/dev-util/gengetopt/gengetopt-2.22.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="a tool to write option parsing code for C programs."
+HOMEPAGE="http://www.gnu.org/software/gengetopt/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ cd src
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd "${S}"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ cd doc
+ dohtml *.html
+ doinfo *.info
+ doman *.1
+ if use examples; then
+ docinto examples
+ dodoc sample{1,2}.ggo main{1.cc,2.c} cmdline{1,2}.{c,h} README.example
+ fi
+}