summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-05-28 19:33:47 +0200
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-05-28 19:33:47 +0200
commitf47c0e01a3dc22d6fbcf5c7a3df5ce4ca1be1cc8 (patch)
tree0561686dec81a845ec6a830cfb8e6c111b7d2b96
parent[dev-python/pygpgme] initial import, work in progress (diff)
downloadxarthisius-f47c0e01a3dc22d6fbcf5c7a3df5ce4ca1be1cc8.tar.gz
xarthisius-f47c0e01a3dc22d6fbcf5c7a3df5ce4ca1be1cc8.tar.bz2
xarthisius-f47c0e01a3dc22d6fbcf5c7a3df5ce4ca1be1cc8.zip
[app-admin/python-updater] add git live version
-rw-r--r--app-admin/modules/Manifest2
-rw-r--r--app-admin/modules/modules-3.2.9c.ebuild51
-rw-r--r--app-admin/python-updater/Manifest2
-rw-r--r--app-admin/python-updater/metadata.xml5
-rw-r--r--app-admin/python-updater/python-updater-9999.ebuild32
5 files changed, 92 insertions, 0 deletions
diff --git a/app-admin/modules/Manifest b/app-admin/modules/Manifest
new file mode 100644
index 0000000..5224a6e
--- /dev/null
+++ b/app-admin/modules/Manifest
@@ -0,0 +1,2 @@
+DIST modules-3.2.9c.tar.gz 439742 RMD160 0f323eb558a676ed8682b82b8b7794029e48934a SHA1 aef309f2c8071f405a3abc773bd686df8ef4d018 SHA256 f0d90d1cd031109c5dedb1b3465d1e1b49fa45bebb6587105757cae735804f95
+EBUILD modules-3.2.9c.ebuild 1126 RMD160 942d48f7f9e49e776b8dd42ada055623b7794631 SHA1 3261a580b74e0d40759f46a725f4b21da0adf25f SHA256 9c4c1025a52627857c2bdcc2c181e96c22e15c0c181a87406e59991931f324c7
diff --git a/app-admin/modules/modules-3.2.9c.ebuild b/app-admin/modules/modules-3.2.9c.ebuild
new file mode 100644
index 0000000..2a60dd7
--- /dev/null
+++ b/app-admin/modules/modules-3.2.9c.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Allows for dynamic modification of a user's environment via modulefiles"
+HOMEPAGE="http://modules.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/tcl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ export _modules_path=/var/lib/Modules/${MY_PV}
+}
+
+src_configure() {
+ # unfortunately {module,version}-path don't work properly
+ ./configure \
+ --prefix=/var/lib \
+ --mandir=/usr/share \
+ --with-module-path=${_modules_path}/modulefiles \
+ --with-version-path=${_modules_path}/versions \
+ --disable-use-default \
+ ${EXTRA_ECONF} || die
+}
+
+src_install() {
+ default
+ dosym ${_modules_path} /var/lib/Modules/default
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add this line at the end of /etc/bash/bashrc:"
+ einfo " [ -e \"${_modules_path}/init/bash\" ] && source \"${_modules_path}/init/bash\""
+ echo
+}
diff --git a/app-admin/python-updater/Manifest b/app-admin/python-updater/Manifest
new file mode 100644
index 0000000..553e9a9
--- /dev/null
+++ b/app-admin/python-updater/Manifest
@@ -0,0 +1,2 @@
+EBUILD python-updater-9999.ebuild 743 RMD160 c6e79d928b24558c3632bca3527dee85c5fca870 SHA1 7be436a3ec22c74705977ed260d68f1b60372bca SHA256 7d9e307e14cf6d42cc0683f801a8620c4d01bec6547c6e7b9f098c6eb3f0adbf
+MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
diff --git a/app-admin/python-updater/metadata.xml b/app-admin/python-updater/metadata.xml
new file mode 100644
index 0000000..de483c5
--- /dev/null
+++ b/app-admin/python-updater/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/app-admin/python-updater/python-updater-9999.ebuild b/app-admin/python-updater/python-updater-9999.ebuild
new file mode 100644
index 0000000..5b7f0bc
--- /dev/null
+++ b/app-admin/python-updater/python-updater-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/python-updater/python-updater-9999.ebuild,v 1.8 2011/12/30 17:41:45 maksbotan Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="http://git.overlays.gentoo.org/gitroot/proj/${PN}.git"
+
+inherit git-2
+
+DESCRIPTION="Script used to reinstall Python packages after changing of active Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="sys-apps/help2man"
+RDEPEND="dev-lang/python
+ || ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 )"
+
+src_compile() {
+ emake ${PN}.1
+}
+
+src_install() {
+ dosbin ${PN}
+ doman ${PN}.1
+ dodoc AUTHORS
+}