aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-10-15 11:23:13 +0300
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-10-15 11:23:13 +0300
commit139e4e108b2c2b9a12ac14cc06e89f93f3925220 (patch)
tree21a2b9f872571b3ad7cc385c5699ee0c1d3693de
parentvim-7.3 crosscompilation fix uint32_t check (diff)
downloadembedded-cross-139e4e108b2c2b9a12ac14cc06e89f93f3925220.tar.gz
embedded-cross-139e4e108b2c2b9a12ac14cc06e89f93f3925220.tar.bz2
embedded-cross-139e4e108b2c2b9a12ac14cc06e89f93f3925220.zip
pam-1.1.2 crosscompilation fix
http://bugs.gentoo.org/show_bug.cgi?id=339174 Signed-off-by: Maksim 'max_posedon' Melnikau <maxposedon@gmail.com>
-rw-r--r--sys-libs/pam/Manifest3
-rw-r--r--sys-libs/pam/pam-1.1.2.ebuild192
2 files changed, 195 insertions, 0 deletions
diff --git a/sys-libs/pam/Manifest b/sys-libs/pam/Manifest
index f69aa37..c12fe65 100644
--- a/sys-libs/pam/Manifest
+++ b/sys-libs/pam/Manifest
@@ -17,6 +17,9 @@ DIST Linux-PAM-1.1.0-docs.tar.bz2 494697 RMD160 324f4cdabbaaa85ac5afca9babea1bfe
DIST Linux-PAM-1.1.0.tar.bz2 1106379 RMD160 b57473ac39ef5c5ec22459e78e00abdbead396e5 SHA1 1ef5b91bf483ecf31e8f07c3c0322b397b13af70 SHA256 139b1abb0f1c402e443ad9083b5ff0512f4a5ae7bc806528e9d7eced13384ed7
DIST Linux-PAM-1.1.1-docs.tar.bz2 495534 RMD160 182639c3fa79c96dbc263f2d16346345949bb0c8 SHA1 9e25f276546844bb5a58f30b5e5d5a97d25c5af5 SHA256 89950180aba6e5e05671c43d970d9738fd2b71b1421a2cf4d504f5c529586ac6
DIST Linux-PAM-1.1.1.tar.bz2 1120055 RMD160 2d3c39cb2c3542d380e1331fef08c7086cc829d9 SHA1 8baf11b04396230ba7cf8b2bfb2d2bd75aab8fa6 SHA256 608d3eb9d7a5e1a7505fff62e6a583fdb6e52dc05bf54dc9661c5f395b1fb904
+DIST Linux-PAM-1.1.2-docs.tar.bz2 495644 RMD160 e695b328eeb5d122f6bdd3793bacad43a3932828 SHA1 b6f5e2735c88e6505e7275c483c4499af8f56422 SHA256 7d336f696c4338dac7630fbb36c818c0dcfb59e180cf42361069a8bf6d422958
+DIST Linux-PAM-1.1.2.tar.bz2 1114503 RMD160 9758433b4189aa80c2e706eb0aaad1a5d07f931a SHA1 6655628f9770594158363915cf2ae415f253560b SHA256 b4f41864581fc9c4cfd7b7cb2a8858bc49605f19723c1a8e32b3c431ced9f698
EBUILD pam-1.0.4.ebuild 5903 RMD160 7648a493da401d5c1510300d656979be3cf408b6 SHA1 eb745c0d87631d6d60503c1d64cf9dca68bb0308 SHA256 b6ec7a808780caa66ee91154542fd183d099abe1e47b0401e02618eeeb0d45b1
EBUILD pam-1.1.0.ebuild 4998 RMD160 db5d7014253428326f8ac1eb0448030583fa425c SHA1 f88307702510ac4d294d7d82010ee6559c6cf017 SHA256 6265cdae5b871bed62c80bb4c0710c29c74b685bb94ded007a839861337f41a5
EBUILD pam-1.1.1-r2.ebuild 5785 RMD160 1dbfcae32ba0ffddfe8324a2c0ee69e20e494924 SHA1 893bd01262e5eed24b7696552ef639b77429db77 SHA256 58c5a86de47d33ba626043e56a0ffe45d16525b3992ea424d7f3d50238f68ce8
+EBUILD pam-1.1.2.ebuild 6136 RMD160 fc8ee206943db2b754da1348e875da002e20b107 SHA1 952281ac2da896fffb1bf1fbc872e76890399e08 SHA256 75334363ac9baba05cd189ad9c17c8efe115d9d2daa54de9a4d0542da850217f
diff --git a/sys-libs/pam/pam-1.1.2.ebuild b/sys-libs/pam/pam-1.1.2.ebuild
new file mode 100644
index 0000000..90b6c6b
--- /dev/null
+++ b/sys-libs/pam/pam-1.1.2.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-1.1.2.ebuild,v 1.1 2010/08/31 12:32:45 flameeyes Exp $
+
+EAPI="3"
+
+inherit libtool multilib eutils autotools pam toolchain-funcs flag-o-matic db-use
+
+MY_PN="Linux-PAM"
+MY_P="${MY_PN}-${PV}"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/libs/pam/"
+DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
+
+SRC_URI="mirror://kernel/linux/libs/pam/library/${MY_P}.tar.bz2
+ mirror://kernel/linux/libs/pam/documentation/${MY_P}-docs.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="cracklib nls elibc_FreeBSD selinux vim-syntax audit test elibc_glibc debug berkdb"
+
+RDEPEND="nls? ( virtual/libintl )
+ cracklib? ( >=sys-libs/cracklib-2.8.3 )
+ audit? ( sys-process/audit )
+ selinux? ( >=sys-libs/libselinux-1.28 )
+ berkdb? ( sys-libs/db )
+ elibc_glibc? ( >=sys-libs/glibc-2.7 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+PDEPEND="sys-auth/pambase
+ vim-syntax? ( app-vim/pam-syntax )"
+RDEPEND="${RDEPEND}
+ !sys-auth/pam_userdb"
+
+S="${WORKDIR}/${MY_P}"
+
+PROVIDE="virtual/pam"
+
+check_old_modules() {
+ local retval="0"
+
+ if sed -e 's:#.*::' "${EROOT}"/etc/pam.d/* 2>/dev/null | fgrep -q pam_stack.so; then
+ eerror ""
+ eerror "Your current setup is using the pam_stack module."
+ eerror "This module is deprecated and no longer supported, and since version"
+ eerror "0.99 is no longer installed, nor provided by any other package."
+ eerror "The package will be built (to allow binary package builds), but will"
+ eerror "not be installed."
+ eerror "Please replace pam_stack usage with proper include directive usage,"
+ eerror "following the PAM Upgrade guide at the following URL"
+ eerror " http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml"
+ eerror ""
+
+ retval=1
+ fi
+
+ if sed -e 's:#.*::' "${EROOT}"/etc/pam.d/* 2>/dev/null | egrep -q 'pam_(pwdb|console)'; then
+ eerror ""
+ eerror "Your current setup is using one or more of the following modules,"
+ eerror "that are not built or supported anymore:"
+ eerror "pam_pwdb, pam_console"
+ eerror "If you are in real need for these modules, please contact the maintainers"
+ eerror "of PAM through http://bugs.gentoo.org/ providing information about its"
+ eerror "use cases."
+ eerror "Please also make sure to read the PAM Upgrade guide at the following URL:"
+ eerror " http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml"
+ eerror ""
+
+ retval=1
+ fi
+
+ return $retval
+}
+
+pkg_setup() {
+ check_old_modules
+}
+
+src_prepare() {
+ # Avoid building xtests during "make all"; note that for what
+ # we're concerned xtests are not even executed, so we should
+ # probably use EXTRA_PROGRAMS.
+ epatch "${FILESDIR}/${MY_PN}-0.99.8.1-xtests.patch"
+
+ # Fix tests to find Berkeley DB as installed by Gentoo (with a
+ # library suffix but no suffix on the ELF symbols).
+ epatch "${FILESDIR}/${MY_PN}-1.1.1-gentoodb.patch"
+
+ # Fix building of doc/specs, see bug 339174
+ epatch "${FILESDIR}/${MY_PN}-1.0.4-cross-compile.patch"
+
+ # Remove libtool-2 libtool macros, see bug 261167
+ rm m4/libtool.m4 m4/lt*.m4 || die "rm libtool macros failed."
+
+ eautoreconf
+
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+
+ if use hppa || use elibc_FreeBSD; then
+ myconf="${myconf} --disable-pie"
+ fi
+
+ # Disable automatic detection of libxcrypt; we _don't_ want the
+ # user to link libxcrypt in by default, since we won't track the
+ # dependency and allow to break PAM this way.
+ export ac_cv_header_xcrypt_h=no
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --enable-securedir="${EPREFIX}"/$(get_libdir)/security \
+ --enable-isadir="${EPREFIX}"/$(get_libdir)/security \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ $(use_enable cracklib) \
+ $(use_enable audit) \
+ $(use_enable debug) \
+ $(use_enable berkdb db) \
+ --with-db-uniquename=-$(db_findver sys-libs/db) \
+ --disable-prelude \
+ ${myconf}
+}
+
+src_compile() {
+ emake sepermitlockdir="${EPREFIX}/var/run/sepermit" || die "emake failed"
+}
+
+src_test() {
+ # explicitly allow parallel-build during testing
+ emake sepermitlockdir="${EPREFIX}/var/run/sepermit" check || die "emake check failed"
+}
+
+src_install() {
+ local lib
+
+ emake DESTDIR="${D}" install \
+ sepermitlockdir="${EPREFIX}/var/run/sepermit" || die "make install failed"
+
+ # Need to be suid
+ fperms u+s /sbin/unix_chkpwd
+
+ gen_usr_ldscript -a pam pamc pam_misc
+
+ # create extra symlinks just in case something depends on them...
+ for lib in pam pamc pam_misc; do
+ if ! [[ -f "${ED}"/$(get_libdir)/lib${lib}$(get_libname) ]]; then
+ dosym lib${lib}$(get_libname 0) /$(get_libdir)/lib${lib}$(get_libname)
+ fi
+ done
+
+ dodoc CHANGELOG ChangeLog README AUTHORS Copyright NEWS || die
+
+ docinto modules
+ for dir in modules/pam_*; do
+ newdoc "${dir}"/README README."$(basename "${dir}")"
+ done
+
+ # Get rid of the .la files. We certainly don't need them for PAM
+ # modules, and libpam is installed as a shared object only, so we
+ # don't ned them for static linking either.
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_preinst() {
+ check_old_modules || die "deprecated PAM modules still used"
+}
+
+pkg_postinst() {
+ ewarn "Some software with pre-loaded PAM libraries might experience"
+ ewarn "warnings or failures related to missing symbols and/or versions"
+ ewarn "after any update. While unfortunate this is a limit of the"
+ ewarn "implementation of PAM and the software, and it requires you to"
+ ewarn "restart the software manually after the update."
+ ewarn ""
+ ewarn "You can get a list of such software running a command like"
+ ewarn " lsof / | egrep 'DEL.*libpam\\.so'"
+ elog ""
+ elog "Because of a bug present up to version 1.1.1-r2, you might have"
+ elog "an executable /var/log/tallylog file. If it is so, you can safely"
+ elog "correct it by running the command"
+ elog " chmod -x /var/log/tallylog"
+ elog ""
+}