aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub 'cz_jc' Novák <jc.bl.dws@gmail.com>2010-06-28 23:43:05 +0200
committerJakub 'cz_jc' Novák <jc.bl.dws@gmail.com>2010-06-28 23:43:05 +0200
commit9686091c49cc8c63972f55b1aea1c38dd8919f62 (patch)
treed6a48f48b48422e00b3d8b16644b3c8af5f821c1
parentFixed x11-drivers/xf86-video-glamo ebuild (diff)
downloadembedded-cross-9686091c49cc8c63972f55b1aea1c38dd8919f62.tar.gz
embedded-cross-9686091c49cc8c63972f55b1aea1c38dd8919f62.tar.bz2
embedded-cross-9686091c49cc8c63972f55b1aea1c38dd8919f62.zip
xf86-video-glamo further fixes and snapshot
- Made it a lot cleaner - Now doesn't run configure twice - Made a snapshot and marked it stable Thanks again, sleipnir :)
-rw-r--r--portage-flags-target/keywords/xf86-video-glamo1
-rw-r--r--x11-drivers/xf86-video-glamo/Manifest3
-rw-r--r--x11-drivers/xf86-video-glamo/xf86-video-glamo-20100626.ebuild41
-rw-r--r--x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild33
4 files changed, 52 insertions, 26 deletions
diff --git a/portage-flags-target/keywords/xf86-video-glamo b/portage-flags-target/keywords/xf86-video-glamo
new file mode 100644
index 0000000..5a014d9
--- /dev/null
+++ b/portage-flags-target/keywords/xf86-video-glamo
@@ -0,0 +1 @@
+=x11-drivers/xf86-video-glamo-20100626 arm
diff --git a/x11-drivers/xf86-video-glamo/Manifest b/x11-drivers/xf86-video-glamo/Manifest
index 0136a72..b5b8e60 100644
--- a/x11-drivers/xf86-video-glamo/Manifest
+++ b/x11-drivers/xf86-video-glamo/Manifest
@@ -1 +1,2 @@
-EBUILD xf86-video-glamo-9999.ebuild 1021 RMD160 021491c646e91ef5f80c425ce18f5933e85d185e SHA1 353e1a33f78163873b104d6ca686cc162a638ad3 SHA256 168de28bc93b244a09a4683b9e322f53bb6be57b6dd53896cd1fa2c8b432b977
+EBUILD xf86-video-glamo-20100626.ebuild 1016 RMD160 775f07cac2dc51e0c2a0eaedfdffa629a2dcd399 SHA1 2438026d0aff46517c7bc2384ec2e6d1bd73f364 SHA256 d1bdb03e21d7a06bed85c95e15735bfe5107b1f261074fa9a9c7ebb472ee473c
+EBUILD xf86-video-glamo-9999.ebuild 931 RMD160 cb299f603777e74dd0685f904cfc6cfca0549130 SHA1 182495900f8e3b3aaa59630d2922c19b0b05b988 SHA256 bfaf538378530840873dc0881e47d007e8e1fee70bbe68c6b13a76ba4118534f
diff --git a/x11-drivers/xf86-video-glamo/xf86-video-glamo-20100626.ebuild b/x11-drivers/xf86-video-glamo/xf86-video-glamo-20100626.ebuild
new file mode 100644
index 0000000..59ee945
--- /dev/null
+++ b/x11-drivers/xf86-video-glamo/xf86-video-glamo-20100626.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+# This gets set automatically by x-modular when ebuild version
+# ends with 9999*. We have to do it ourselves in a snapshot.
+GIT_ECLASS="git"
+SNAPSHOT="yes"
+SRC_URI=""
+
+# We cannot inherit git here; defining it causes the ebuild to
+# only fetch the git repo and not do anything else.
+# Furthermore, git is automatically inherited by x-modular.
+inherit x-modular
+
+DESCRIPTION="Video driver for SMedia Glamo"
+HOMEPAGE="http://www.openmoko.org/"
+
+EGIT_REPO_URI="git://git.openmoko.org/git/xf86-video-glamo.git"
+EGIT_PROJECT="xf86-video-glamo"
+EGIT_COMMIT="e43cf499d0df41eb6ca2a1a7c21af71e31207635"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.5"
+
+DEPEND="${RDEPEND}
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/videoproto
+ x11-libs/libdrm[video_cards_glamo]"
+
+CONFIGURE_OPTIONS="--enable-kms"
diff --git a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
index ca3e32b..4a5aa99 100644
--- a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
+++ b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
@@ -3,9 +3,11 @@
# $Header: $
EAPI=2
-XDPVER=-1
-SNAPSHOT="yes"
-inherit x-modular git
+
+# We cannot inherit git here; defining it causes the ebuild to
+# only fetch the git repo and not do anything else.
+# Furthermore, git is automatically inherited by x-modular.
+inherit x-modular
DESCRIPTION="Video driver for SMedia Glamo"
HOMEPAGE="http://www.openmoko.org/"
@@ -16,7 +18,7 @@ EGIT_PROJECT="xf86-video-glamo"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~arm"
-IUSE="kms"
+IUSE="+kms"
RDEPEND=">=x11-base/xorg-server-1.5"
@@ -28,29 +30,10 @@ DEPEND="${RDEPEND}
x11-proto/videoproto
x11-libs/libdrm[video_cards_glamo]"
+CONFIGURE_OPTIONS="$(use_enable kms )"
+
pkg_setup() {
if ! use kms ; then
ewarn "If you experience build or run time difficulties, try enabling kms use flag."
fi
}
-
-src_unpack() {
- git_src_unpack
- cd "${S}"
-
- append-flags -Wno-error
- eautoreconf || die "eautoreconf failed"
-}
-
-src_configure() {
- CONFIGURE_OPTIONS="$(use_enable kms )"
- x-modular_src_configure
-}
-
-src_compile() {
- x-modular_src_make
-}
-
-src_install() {
- x-modular_src_install
-}