aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-05-20 06:07:50 +0000
committerUlrich Müller <ulm@gentoo.org>2009-05-20 06:07:50 +0000
commit84f15af402d9d0e1057243259542ce94cf914df0 (patch)
tree34b0f445a54fe91dcda9a537ff6fcfff80005421
parentDon't hardcode /bin/bash in order to be more Prefix-friendly. (diff)
downloadeselect-84f15af402d9d0e1057243259542ce94cf914df0.tar.gz
eselect-84f15af402d9d0e1057243259542ce94cf914df0.tar.bz2
eselect-84f15af402d9d0e1057243259542ce94cf914df0.zip
Output a message if there are no news items to read.
svn path=/trunk/; revision=553
-rw-r--r--ChangeLog3
-rw-r--r--configure.ac1
-rw-r--r--modules/news-tng.eselect1
3 files changed, 4 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 9b5690b..68ba97a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
2009-05-19 Ulrich Mueller <ulm@gentoo.org>
+ * modules/news-tng.eselect (do_read): Output a message if there
+ are no news items to read.
+
* bin/eselect.in: Don't hardcode /bin/bash; use configured path
instead, as requested by Fabian Groffen <grobian@gentoo.org>.
* bin/Makefile.am (dosed): Also substitute BASH. Use at signs
diff --git a/configure.ac b/configure.ac
index 329f24b..d6a6726 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,4 +85,3 @@ AC_OUTPUT(Makefile
bin/Makefile
libs/Makefile
modules/Makefile)
-
diff --git a/modules/news-tng.eselect b/modules/news-tng.eselect
index 54d4a07..1be4ea5 100644
--- a/modules/news-tng.eselect
+++ b/modules/news-tng.eselect
@@ -186,6 +186,7 @@ do_read() {
seq="${seq} ${i}"
done
set -- ${seq}
+ [[ $# -eq 0 && -z ${raw} ]] && echo "No news is good news."
fi
for i in "$@"; do