summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-01-08 21:53:12 +0100
committerUlrich Müller <ulm@gentoo.org>2022-01-08 21:53:12 +0100
commit62501cdddf09cd92689fb5e8f87c4369fd636cf5 (patch)
tree767c9c7304873ee7788924793227796298888fd5
parentUpdate version to 1.4.19 (diff)
downloadeselect-62501cdddf09cd92689fb5e8f87c4369fd636cf5.tar.gz
eselect-62501cdddf09cd92689fb5e8f87c4369fd636cf5.tar.bz2
eselect-62501cdddf09cd92689fb5e8f87c4369fd636cf5.zip
Error out if --root has no option argument
* bin/eselect.in: Error out if --root has no option argument. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--ChangeLog2
-rwxr-xr-xbin/eselect.in1
2 files changed, 3 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index d40ac8d..ac7c78b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,7 @@
2022-01-08 Ulrich Müller <ulm@gentoo.org>
+ * bin/eselect.in: Error out if --root has no option argument.
+
* configure.ac: Update version to 1.4.19.
* Tagged 1.4.19 release.
diff --git a/bin/eselect.in b/bin/eselect.in
index 3422197..4caa87e 100755
--- a/bin/eselect.in
+++ b/bin/eselect.in
@@ -150,6 +150,7 @@ while [[ ${1##--} != "$1" ]]; do
action=${1##--}
;;
root=*|root)
+ [[ ${1#*=} == "$1" ]] && die -q "Option $1 requires an argument"
# set ROOT and recalculate EROOT
ROOT=${1#*=}
EROOT="${ROOT%${EPREFIX:+/}}${EPREFIX}"