summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-06-07 10:50:02 +0200
committerUlrich Müller <ulm@gentoo.org>2023-06-07 10:50:02 +0200
commit9869b3f98c95ec154b7ac5b2af8bcf6201d8127a (patch)
tree7b23634a287e97901f0dd3248cb2f0e3f3a469f1
parentUpdate version to 1.4.24 (diff)
downloadeselect-9869b3f98c95ec154b7ac5b2af8bcf6201d8127a.tar.gz
eselect-9869b3f98c95ec154b7ac5b2af8bcf6201d8127a.tar.bz2
eselect-9869b3f98c95ec154b7ac5b2af8bcf6201d8127a.zip
Use printf instead of echo
* bin/eselect.in (PATH): Use printf instead of echo Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--ChangeLog2
-rwxr-xr-xbin/eselect.in2
2 files changed, 3 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index aba58d1..87efe93 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,7 @@
2023-06-07 Ulrich Müller <ulm@gentoo.org>
+ * bin/eselect.in (PATH): Use printf instead of echo.
+
* configure.ac: Update version to 1.4.24.
* Tagged 1.4.24 release.
diff --git a/bin/eselect.in b/bin/eselect.in
index 41d53d7..36581e1 100755
--- a/bin/eselect.in
+++ b/bin/eselect.in
@@ -62,7 +62,7 @@ umask +rx
# Sanitise PATH: We don't want to execute Portage's internal helpers
# if we're called from an ebuild.
IFS=:
-read -r -d '' -a path < <(echo -n "${PATH}")
+read -r -d '' -a path < <(printf '%s\0' "${PATH}")
for i in "${!path[@]}"; do
[[ ${path[i]} == */portage?(/*)/ebuild-helpers?(/*) ]] && unset "path[i]"
done