summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-01-18 00:56:57 +0100
committerUlrich Müller <ulm@gentoo.org>2015-01-18 00:56:57 +0100
commit54c428513a6a7d4d2b773f056237f4ee2cd8d857 (patch)
tree768eec79286da7f06ff6748b00a586141bf2a4f3
parentBe compatible with new OpenRC in rc module. (diff)
downloadeselect-54c428513a6a7d4d2b773f056237f4ee2cd8d857.tar.gz
eselect-54c428513a6a7d4d2b773f056237f4ee2cd8d857.tar.bz2
eselect-54c428513a6a7d4d2b773f056237f4ee2cd8d857.zip
Use "git describe --long" in configure.
* configure.ac (EXTRAVERSION): Use "git describe --long".
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac2
2 files changed, 5 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 01b8d14..22cab2a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2015-01-18 Ulrich Müller <ulm@gentoo.org>
+
+ * configure.ac (EXTRAVERSION): Use "git describe --long".
+
2015-01-17 Ulrich Müller <ulm@gentoo.org>
* modules/rc.eselect: Be compatible with new OpenRC, bug 536822.
diff --git a/configure.ac b/configure.ac
index ab6e76a..d2eb07d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,7 +78,7 @@ AC_SUBST(EPREFIX)
AC_MSG_CHECKING([whether building from git])
EXTRAVERSION=""
if test -d ${GIT_DIR:-.git}; then
- COMMIT=`git describe --always HEAD`
+ COMMIT=`git describe --long --always HEAD`
if test x$COMMIT != x; then
EXTRAVERSION=", git commit $COMMIT"
fi