aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog6
-rw-r--r--NEWS4
-rw-r--r--libs/skel.bash.in2
3 files changed, 11 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 42e8d53..0835162 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2009-11-15 Ulrich Mueller <ulm@gentoo.org>
+
+ * libs/skel.bash.in (do_add): Respect EPREFIX also when called
+ from within an ebuild environment. Patch from Fabian Groffen
+ <grobian@gentoo.org> in bug 293317.
+
2009-11-13 Ulrich Mueller <ulm@gentoo.org>
* configure.ac: Update version to 1.2.7.
diff --git a/NEWS b/NEWS
index 3cae701..d2963e7 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,10 @@
This file contains a summary of changes in released versions. Please read the
ChangeLog file for a more detailed listing of changes/bug fixes.
+trunk:
+ Bug fixes:
+ - Fixed bug #293317: Use EPREFIX in skel library when called from ebuild.
+
1.2.7:
Bug fixes:
- Fixed bug #289095: Proper ROOT handling in multilib library.
diff --git a/libs/skel.bash.in b/libs/skel.bash.in
index 9db20af..ba8bcf3 100644
--- a/libs/skel.bash.in
+++ b/libs/skel.bash.in
@@ -293,7 +293,7 @@ do_add() {
# If $D is set, we're adding from portage so we want to respect sandbox.
# Otherwise, respect the ROOT variable.
- local prefix=${D:-${EROOT}}
+ local prefix=${D:-${ROOT}}${EPREFIX}
# Create directory if necessary
if [[ ! -e ${prefix}/etc/env.d/${IFACE}/${1} ]]; then