summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Kicherer <dev@kicherer.org>2015-01-01 21:03:37 +0100
committerMario Kicherer <dev@kicherer.org>2015-01-01 21:03:37 +0100
commit7883796a51684247d5f15b66d05bfd53fe2da6b7 (patch)
tree4dbcc1731c563e75566e9260bd792148fd4eb9bc
parentremoved some more unmaintained stuff (diff)
downloadgamerlay-7883796a51684247d5f15b66d05bfd53fe2da6b7.tar.gz
gamerlay-7883796a51684247d5f15b66d05bfd53fe2da6b7.tar.bz2
gamerlay-7883796a51684247d5f15b66d05bfd53fe2da6b7.zip
[games-util/steam-launcher] new 1.0.0.49, sync with steam-overlay
-rw-r--r--games-util/steam-launcher/Manifest1
-rw-r--r--games-util/steam-launcher/metadata.xml6
-rw-r--r--games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild112
3 files changed, 113 insertions, 6 deletions
diff --git a/games-util/steam-launcher/Manifest b/games-util/steam-launcher/Manifest
index dc2034b..c56fb06 100644
--- a/games-util/steam-launcher/Manifest
+++ b/games-util/steam-launcher/Manifest
@@ -1 +1,2 @@
DIST steam_1.0.0.47.tar.gz 2326735 SHA256 1de4e1abe5bb3eecbde66d66c238ff79d083d31897f0c008f5e345889d9deac3 SHA512 482c2fd5291e83b08d8a8d2559e82bd9cedd5018c6e7c4b4c9718e4e1b5a51217699f59a8ccfd8ca3b9a8a743a4ab4c81a7a9ec49e0796c7c4b170b68dd2911a WHIRLPOOL 491c71de0fd80b6986992ad5011738f39cd5d7782d453a8e12d1abacf919819a69465a8de9ade52f5c5cd1bcc73b53005ab46a2be83342200c777be1b00461f4
+DIST steam_1.0.0.49.tar.gz 2179436 SHA256 fd893b5c2f5585be1cd8a83f4a6c7d523a2bd985a91587adb5afaccd6fa12fb0 SHA512 52a26bee229dfaf5bb0974340edaa4e07a7a8aa908b6e5187b61933ffbb9848cf6ea4803890334d976126c3a20b91d040a49782163000421beff0e9a036d144a WHIRLPOOL 8350e6f45f74cdfa310b94214ae367006fa824a4509d33ecad9f5f5f852990cb62af7be00c007de1a926172aa2a83b3658de809ab8f23f3496ea537f6c0bf623
diff --git a/games-util/steam-launcher/metadata.xml b/games-util/steam-launcher/metadata.xml
index 982aa7f..40fb94f 100644
--- a/games-util/steam-launcher/metadata.xml
+++ b/games-util/steam-launcher/metadata.xml
@@ -12,10 +12,4 @@
<upstream>
<bugs-to>https://github.com/anyc/steam-overlay</bugs-to>
</upstream>
- <use>
- <flag name='steamruntime'>
- Enables the Steam runtime environment that uses bundled
- libraries instead of installed system libraries.
- </flag>
- </use>
</pkgmetadata>
diff --git a/games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild b/games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild
new file mode 100644
index 0000000..2f66fc5
--- /dev/null
+++ b/games-util/steam-launcher/steam-launcher-1.0.0.49.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+# Please report bugs/suggestions on: https://github.com/anyc/steam-overlay
+# or come to #gentoo-gamerlay in freenode IRC
+
+inherit eutils gnome2-utils fdo-mime udev
+
+DESCRIPTION="Installer, launcher and supplementary files for Valve's Steam client"
+HOMEPAGE="http://steampowered.com"
+SRC_URI="http://repo.steampowered.com/steam/pool/steam/s/steam/steam_${PV}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="ValveSteamLicense"
+
+RESTRICT="bindist mirror"
+SLOT="0"
+
+RDEPEND="
+ app-arch/tar
+ app-shells/bash
+ net-misc/curl
+ || (
+ >=gnome-extra/zenity-3
+ x11-terms/xterm
+ )
+
+ amd64? (
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-20121028[-abi_x86_32(-)]
+ (
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXau[abi_x86_32]
+ x11-libs/libxcb[abi_x86_32]
+ x11-libs/libXdmcp[abi_x86_32]
+ )
+ )
+ >=sys-devel/gcc-4.6.0[multilib]
+ >=sys-libs/glibc-2.15[multilib]
+ )
+ x86? (
+ >=sys-devel/gcc-4.6.0
+ >=sys-libs/glibc-2.15
+ >=x11-libs/libX11-1.5
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ )"
+
+S=${WORKDIR}/steam/
+
+src_prepare() {
+ epatch "${FILESDIR}"/steam-fix-ld-library-path.patch
+
+ # we use our ebuild functions to install the files
+ rm Makefile
+}
+
+src_install() {
+ dobin steam
+
+ insinto /usr/lib/steam/
+ doins bootstraplinux_ubuntu12_32.tar.xz
+
+ udev_dorules lib/udev/rules.d/99-steam-controller-perms.rules
+
+ dodoc debian/changelog steam_install_agreement.txt
+ doman steam.6
+
+ domenu steam.desktop
+
+ cd icons/
+ for s in * ; do
+ doicon -s ${s} ${s}/steam.png
+ done
+
+ # tgz archive contains no separate pixmap, see #38
+ insinto /usr/share/pixmaps/
+ newins 48/steam_tray_mono.png steam_tray_mono.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ udev_reload
+
+ elog "Execute /usr/bin/steam to download and install the actual"
+ elog "client into your home folder. After installation, the script"
+ elog "also starts the client from your home folder."
+ elog ""
+
+ if ! has_version "gnome-extra/zenity"; then
+ ewarn "Valve does not provide a xterm fallback for all calls of zenity."
+ ewarn "Please install gnome-extra/zenity for full support."
+ ewarn ""
+ fi
+
+ ewarn "The steam client and the games are _not_ controlled by portage."
+ ewarn "Updates are handled by the client itself."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}