aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2011-03-28 19:24:06 +0200
committerSebastian Pipping <sebastian@pipping.org>2011-03-28 19:24:06 +0200
commitade0b7669be72b77c56d85dcc78761d05815d347 (patch)
treeafb62902bb7db002437d037bbf01f4f5bd390e65
parentFix handling of doslowusb/noslowusb (diff)
parentFix typo "initamfs" (diff)
downloadgenkernel-ade0b7669be72b77c56d85dcc78761d05815d347.tar.gz
genkernel-ade0b7669be72b77c56d85dcc78761d05815d347.tar.bz2
genkernel-ade0b7669be72b77c56d85dcc78761d05815d347.zip
Merge branch 'master' into stable
-rw-r--r--HACKING2
-rw-r--r--doc/genkernel.8.txt2
-rwxr-xr-xgen_compile.sh10
-rw-r--r--patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch11
-rw-r--r--patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch11
5 files changed, 33 insertions, 3 deletions
diff --git a/HACKING b/HACKING
index b379bf4..2626963 100644
--- a/HACKING
+++ b/HACKING
@@ -19,4 +19,4 @@ Rolling a release:
- make dist
- upload genkernel-${PV}.tar.bz2 to the hosting:
scp genkernel-${PV}.tar.bz2 ${USER}@dev.gentoo.org:/space/distfiles-local/
-- check open bugs with keyword "InSVN" for closability
+- check open bugs with keyword "InSVN" or "InVCS" for closability
diff --git a/doc/genkernel.8.txt b/doc/genkernel.8.txt
index a74df82..a78da11 100644
--- a/doc/genkernel.8.txt
+++ b/doc/genkernel.8.txt
@@ -130,7 +130,7 @@ KERNEL COMPILATION
to the second most recently built image, if one exists. Similar
symlinks (both * and *.old) are managed for initramfs and System.map.
The corresponding work products (i.e., the actual kernel
- and initamfs images, and System.map) are also managed accordingly.
+ and initramfs images, and System.map) are also managed accordingly.
NOTE: Specifying *--symlink* does nothing unless
*--install* is also specified.
diff --git a/gen_compile.sh b/gen_compile.sh
index b60b921..ec752ce 100755
--- a/gen_compile.sh
+++ b/gen_compile.sh
@@ -685,10 +685,18 @@ compile_iscsi() {
gen_die "ISCSI directory ${ISCSI_DIR} invalid"
print_info 1 'iSCSI: >> Compiling...'
cd "${TEMP}/${ISCSI_DIR}"
+ apply_patches iscsi ${ISCSI_VER}
# Only build userspace
+ print_info 1 'iSCSI: >> Configuring userspace...'
+ cd utils/open-isns || gen_die 'Could not enter open-isns dir'
+ # we currently have a patch that changes configure.ac
+ # once given patch is dropped, drop autoconf too
+ autoconf || gen_die 'Could not tweak open-iscsi configuration'
+ ./configure --without-slp >> ${LOGFILE} 2>&1 || gen_die 'Could not configure userspace'
+ cd ../.. || gen_die 'wtf?'
MAKE=${UTILS_MAKE} compile_generic "user" ""
-
+
# if kernel modules exist, copy them to initramfs, otherwise it will be compiled into the kernel
mkdir -p "${TEMP}/initramfs-iscsi-temp/lib/modules/${RELEASE}/kernel/drivers/scsi/"
for modname in iscsi_tcp libiscsi scsi_transport_iscsi
diff --git a/patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch b/patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch
new file mode 100644
index 0000000..185f1ac
--- /dev/null
+++ b/patches/iscsi/2.0-872/open-iscsi-2.0.872-omg-calling-configure.patch
@@ -0,0 +1,11 @@
+--- open-iscsi-2.0-872.orig/Makefile
++++ open-iscsi-2.0-872/Makefile
+@@ -27,7 +27,7 @@ IFACEFILES = etc/iface.example
+ all: user kernel
+
+ user: ;
+- cd utils/open-isns; ./configure; $(MAKE)
++ cd utils/open-isns; $(MAKE)
+ $(MAKE) -C utils/sysdeps
+ $(MAKE) -C utils/fwparam_ibft
+ $(MAKE) -C usr
diff --git a/patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch b/patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch
new file mode 100644
index 0000000..51ca3e5
--- /dev/null
+++ b/patches/iscsi/2.0-872/open-iscsi-2.0.872-slp.patch
@@ -0,0 +1,11 @@
+--- a/utils/open-isns/configure.ac
++++ b/utils/open-isns/configure.ac
+@@ -80,7 +80,7 @@ AC_ARG_WITH(slp,
+ else
+ WITH_SLP=yes
+ CPPFLAGS="$CPPFLAGS -I${withval}"
+- LDFLAGS="$LDFLAGS -L${withval}"
++ LDFLAGS="$LDFLAGS -L${withval} -lslp"
+ fi
+ ]
+ )