summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan F <44616e46@gmail.com>2022-05-16 13:20:11 +0100
committerDan F <44616e46@gmail.com>2022-05-16 13:20:39 +0100
commitf0f544fbeb5cf2fabe9c11a743c1507da46ad3b4 (patch)
treeb5d1e6c7e11cf69cd24f759b8ab8c4f33e8b9d35
parentfuse: Add patch to allow building against glibc-2.34 (diff)
downloadgenkernel-f0f544fbeb5cf2fabe9c11a743c1507da46ad3b4.tar.gz
genkernel-f0f544fbeb5cf2fabe9c11a743c1507da46ad3b4.tar.bz2
genkernel-f0f544fbeb5cf2fabe9c11a743c1507da46ad3b4.zip
Updating open-iscsi to 2.1.4
Signed-off-by: DanF <44616e46@gmail.com>
-rw-r--r--patches/open-iscsi/2.0.878/open-iscsi-2.0.878-gcc-10.patch107
-rw-r--r--patches/open-iscsi/2.0.878/open-iscsi-2.0.878-static-iscsistart.patch11
-rw-r--r--patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch (renamed from patches/open-iscsi/2.0.878/open-iscsi-2.0.878-Makefiles.patch)8
-rw-r--r--patches/open-iscsi/2.1.4/open-iscsi-2.1.4-static-iscsistart.patch11
4 files changed, 15 insertions, 122 deletions
diff --git a/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-gcc-10.patch b/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-gcc-10.patch
deleted file mode 100644
index b614765..0000000
--- a/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-gcc-10.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-From 499a006a7d6bb154f9e1ab430e4c9e231ba6096a Mon Sep 17 00:00:00 2001
-From: Lee Duncan <lduncan@suse.com>
-Date: Tue, 28 Jan 2020 16:36:56 -0800
-Subject: [PATCH] Updates to support gcc -fno-common option.
-
-This meant cleaning up the definition of some
-global variables, so that they were only defined
-in one place and refered to as external elsewhere.
----
- include/iscsi_err.h | 6 ++++--
- iscsiuio/configure.ac | 2 +-
- iscsiuio/src/uip/uip.h | 4 ++--
- usr/iscsi_err.c | 2 ++
- usr/log.c | 1 +
- usr/log.h | 2 +-
- 6 files changed, 11 insertions(+), 6 deletions(-)
-
-diff --git a/include/iscsi_err.h b/include/iscsi_err.h
-index ed000dd0..04a8723e 100644
---- a/include/iscsi_err.h
-+++ b/include/iscsi_err.h
-@@ -4,7 +4,7 @@
- #ifndef _ISCSI_ERR_
- #define _ISCSI_ERR_
-
--enum {
-+enum iscsi_error_list {
- ISCSI_SUCCESS = 0,
- /* Generic error */
- ISCSI_ERR = 1,
-@@ -73,7 +73,9 @@ enum {
-
- /* Always last. Indicates end of error code space */
- ISCSI_MAX_ERR_VAL,
--} iscsi_err;
-+};
-+
-+extern enum iscsi_error_list iscsi_err;
-
- extern void iscsi_err_print_msg(int err);
- extern char *iscsi_err_to_str(int err);
-diff --git a/iscsiuio/configure.ac b/iscsiuio/configure.ac
-index b41df0ec..8099f09c 100644
---- a/iscsiuio/configure.ac
-+++ b/iscsiuio/configure.ac
-@@ -78,7 +78,7 @@ AC_CONFIG_COMMANDS([default],[[
- else
- echo 'char *build_date = "'`date`'";' > src/unix/build_date.c
- fi
-- echo 'char *build_date;'> src/unix/build_date.h
-+ echo 'extern char *build_date;'> src/unix/build_date.h
- ]],[[]])
-
- AC_PREFIX_DEFAULT()
-diff --git a/iscsiuio/src/uip/uip.h b/iscsiuio/src/uip/uip.h
-index 1180ab50..9d9428a2 100644
---- a/iscsiuio/src/uip/uip.h
-+++ b/iscsiuio/src/uip/uip.h
-@@ -70,8 +70,8 @@ struct uip_stack;
- typedef u16_t uip_ip4addr_t[2];
- typedef u16_t uip_ip6addr_t[8];
-
--const uip_ip6addr_t all_zeroes_addr6;
--const uip_ip4addr_t all_zeroes_addr4;
-+extern const uip_ip6addr_t all_zeroes_addr6;
-+extern const uip_ip4addr_t all_zeroes_addr4;
-
- #define ETH_BUF(buf) ((struct uip_eth_hdr *)buf)
- #define VLAN_ETH_BUF(buf) ((struct uip_vlan_eth_hdr *)buf)
-diff --git a/usr/iscsi_err.c b/usr/iscsi_err.c
-index 23c61fc3..4a057d57 100644
---- a/usr/iscsi_err.c
-+++ b/usr/iscsi_err.c
-@@ -21,6 +21,8 @@
- #include "iscsi_err.h"
- #include "log.h"
-
-+enum iscsi_error_list iscsi_err;
-+
- static char *iscsi_err_msgs[] = {
- /* 0 */ "",
- /* 1 */ "unknown error",
-diff --git a/usr/log.c b/usr/log.c
-index f29b54b3..6e16e7ce 100644
---- a/usr/log.c
-+++ b/usr/log.c
-@@ -33,6 +33,7 @@
-
- char *log_name;
- int log_level = 0;
-+struct logarea *la = NULL;
-
- static int log_stop_daemon = 0;
- static void (*log_func)(int prio, void *priv, const char *fmt, va_list ap);
-diff --git a/usr/log.h b/usr/log.h
-index 486a08ea..c548791e 100644
---- a/usr/log.h
-+++ b/usr/log.h
-@@ -64,7 +64,7 @@ struct logarea {
- union semun semarg;
- };
-
--struct logarea *la;
-+extern struct logarea *la;
-
- extern int log_init(char *program_name, int size,
- void (*func)(int prio, void *priv, const char *fmt, va_list ap),
diff --git a/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-static-iscsistart.patch b/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-static-iscsistart.patch
deleted file mode 100644
index 2b06109..0000000
--- a/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-static-iscsistart.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/usr/Makefile
-+++ b/usr/Makefile
-@@ -74,7 +74,7 @@ iscsiadm: $(ISCSI_LIB_SRCS) $(DISCOVERY_SRCS) iscsiadm.o session_mgmt.o mntcheck
-
- iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
- iscsistart.o statics.o
-- $(CC) $(CFLAGS) $^ -o $@ -lrt $(LDFLAGS) $(ISCSI_LIB)
-+ $(CC) $(CFLAGS) $^ -o $@ -static -lrt $(LDFLAGS) $(ISCSI_LIB)
- clean:
- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
-
diff --git a/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-Makefiles.patch b/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch
index b45ff6e..2488b73 100644
--- a/patches/open-iscsi/2.0.878/open-iscsi-2.0.878-Makefiles.patch
+++ b/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-Makefiles.patch
@@ -9,7 +9,7 @@
LIBISCSI_USR_DIR=$(TOPDIR)/libopeniscsiusr
-@@ -44,17 +44,18 @@ EXTRA_MAN_FILES = libopeniscsiusr.h.3
+@@ -45,17 +45,18 @@ EXTRA_MAN_FILES = libopeniscsiusr.h.3
OBJS = context.o misc.o session.o sysfs.o iface.o idbm.o node.o default.o
CFLAGS ?= -O2 -g
@@ -40,10 +40,10 @@
+PKG_CONFIG ?= pkg-config
CFLAGS ?= -O2 -g
- WARNFLAGS ?= -Wall -Wstrict-prototypes
-@@ -76,9 +76,9 @@ iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
+ WARNFLAGS ?= -Wall -Wextra -Werror -Wstrict-prototypes -fno-common
+@@ -78,9 +78,9 @@ iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
iscsistart.o statics.o
- $(CC) $(CFLAGS) $^ -o $@ -static -lrt $(LDFLAGS) $(ISCSI_LIB)
+ $(CC) $(CFLAGS) $^ -o $@ -lcrypto -lrt $(LDFLAGS) $(ISCSI_LIB)
clean:
- rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
+ $(RM) *.o $(PROGRAMS) .depend $(LIBSYS)
diff --git a/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-static-iscsistart.patch b/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-static-iscsistart.patch
new file mode 100644
index 0000000..b84ba92
--- /dev/null
+++ b/patches/open-iscsi/2.1.4/open-iscsi-2.1.4-static-iscsistart.patch
@@ -0,0 +1,11 @@
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -76,7 +76,7 @@ $(CC) $(CFLAGS) $^ -o $@ -lisns -lcrypto -lmount $(LDFLAGS) $(ISCSI_LIB)
+
+ iscsistart: $(ISCSI_LIB_SRCS) $(INITIATOR_SRCS) $(FW_BOOT_SRCS) \
+ iscsistart.o statics.o
+- $(CC) $(CFLAGS) $^ -o $@ -lcrypto -lrt $(LDFLAGS) $(ISCSI_LIB)
++ $(CC) $(CFLAGS) $^ -o $@ -static -lcrypto -lrt $(LDFLAGS) $(ISCSI_LIB)
+ clean:
+ $(RM) *.o $(PROGRAMS) .depend $(LIBSYS)
+