aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-08 22:45:32 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-08 22:45:32 +0100
commit9918ecbc6bb90e8dafb361928642aff805e7997f (patch)
treea7673a8c82953065761dca062d5b7dbaa01c0f20
parentVersion bumped. (diff)
downloadgentoo-vdr-scripts-eselect-module.tar.gz
gentoo-vdr-scripts-eselect-module.tar.bz2
gentoo-vdr-scripts-eselect-module.zip
backported source from existing version 0.0.4 to git repoeselect-module
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--Makefile2
-rw-r--r--vdr-plugin.eselect25
2 files changed, 13 insertions, 14 deletions
diff --git a/Makefile b/Makefile
index da3d66e..114ed14 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-VERSION = 0.0.3
+VERSION = 0.0.4
ARCHIVE = eselect-vdr-$(VERSION)
TMPDIR = /tmp
diff --git a/vdr-plugin.eselect b/vdr-plugin.eselect
index c266015..80bc8f9 100644
--- a/vdr-plugin.eselect
+++ b/vdr-plugin.eselect
@@ -1,14 +1,15 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Id: bashcomp.eselect 367 2007-03-28 14:35:23Z pioto $
+# Author: Matthias Schwarzott <zzam@gentoo.org>
+# Author: Joerg Bornkessel <hd_brummy@gentoo.org>
DESCRIPTION="Manage VDR plugins"
-MAINTAINER="zzam@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
+MAINTAINER="vdr@gentoo.org"
+
+inherit multilib
find_plugins() {
- local plugins plugin f plugindir="${ROOT}/usr/lib/vdr/plugins"
+ local plugins plugin f plugindir="${EROOT}/usr/${get_libdir)/vdr/plugins"
for f in ${plugindir}/libvdr-*.so* ; do
[[ -e ${f} ]] || continue
@@ -22,7 +23,7 @@ find_plugins() {
}
show_enabled_plugins() {
- local plugins line conffile="${ROOT}/etc/conf.d/vdr.plugins"
+ local plugins line conffile="${EROOT}/etc/conf.d/vdr.plugins"
exec 3<${conffile}
while read plugin <&3; do
@@ -35,14 +36,14 @@ show_enabled_plugins() {
}
is_enabled() {
- local conffile="${ROOT}/etc/conf.d/vdr.plugins"
+ local conffile="${EROOT}/etc/conf.d/vdr.plugins"
egrep -q "^${1}\$" "${conffile}" || return 1
return 0
}
plugin_exists() {
- local f plugindir="${ROOT}/usr/lib/vdr/plugins"
+ local f plugindir="${EROOT}/usr/$(get_libdir)/vdr/plugins"
for f in ${plugindir}/libvdr-${1}.so.*; do
[[ -e "${f}" ]] && return 0
@@ -108,7 +109,7 @@ describe_enable_options() {
}
do_enable() {
- local conffile="${ROOT}/etc/conf.d/vdr.plugins" plugins plugin
+ local conffile="${EROOT}/etc/conf.d/vdr.plugins" plugins plugin
[[ -z ${1} ]] && die -q "You didn't specify any plugins to enable."
@@ -165,7 +166,7 @@ describe_disable_options() {
do_disable() {
- local conffile="${ROOT}/etc/conf.d/vdr.plugins" plugins plugin
+ local conffile="${EROOT}/etc/conf.d/vdr.plugins" plugins plugin
[[ -z ${1} ]] && die -q "You didn't specify any plugins to disable"
@@ -197,5 +198,3 @@ do_disable() {
sed -e "/^${plugin}\$/d" -i "${conffile}"
done
}
-
-# vim: set ft=eselect :