aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch')
-rw-r--r--media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch b/media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch
new file mode 100644
index 00000000..6f0c0c96
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch
@@ -0,0 +1,46 @@
+diff -uNr a/app/base/base-utils.c b/app/base/base-utils.c
+--- a/app/base/base-utils.c 2013-07-22 20:47:46.115387637 +0200
++++ b/app/base/base-utils.c 2013-07-22 20:49:11.034392213 +0200
+@@ -29,7 +29,7 @@
+ #include <process.h>
+ #endif
+
+-#ifdef G_OS_UNIX
++#if defined(G_OS_UNIX) && defined(HAVE_EXECINFO_H)
+ /* For get_backtrace() */
+ #include <stdlib.h>
+ #include <string.h>
+@@ -112,7 +112,7 @@
+ char *
+ get_backtrace (void)
+ {
+-#ifdef G_OS_UNIX
++#if defined(G_OS_UNIX) && defined(HAVE_EXECINFO_H)
+ void *functions[MAX_FUNC];
+ char **function_names;
+ int n_functions;
+diff -uNr a/config.h.in b/config.h.in
+--- a/config.h.in 2013-07-22 20:47:46.454387655 +0200
++++ b/config.h.in 2013-07-22 20:50:43.809397212 +0200
+@@ -26,6 +26,9 @@
+ /* always defined to indicate that i18n is enabled */
+ #undef ENABLE_NLS
+
++/* Define to 1 if you have the <execinfo.h> header file. */
++#undef HAVE_EXECINFO_H
++
+ /* The prefix for our gettext translation domains. */
+ #undef GETTEXT_PACKAGE
+
+diff -uNr a/configure.ac b/configure.ac
+--- a/configure.ac 2013-07-22 20:47:46.018387632 +0200
++++ b/configure.ac 2013-07-22 20:49:59.201394808 +0200
+@@ -416,7 +416,7 @@
+ AC_HEADER_SYS_WAIT
+ AC_HEADER_TIME
+
+-AC_CHECK_HEADERS(sys/param.h sys/time.h sys/times.h sys/wait.h unistd.h)
++AC_CHECK_HEADERS(execinfo.h sys/param.h sys/time.h sys/times.h sys/wait.h unistd.h)
+
+ AC_TYPE_PID_T
+ AC_FUNC_VPRINTF