aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gimp/files')
-rw-r--r--media-gfx/gimp/files/gimp-2.7.4-no-deprecation.patch36
-rw-r--r--media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch46
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/gimp/files/gimp-2.7.4-no-deprecation.patch b/media-gfx/gimp/files/gimp-2.7.4-no-deprecation.patch
new file mode 100644
index 00000000..66bd93d0
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.7.4-no-deprecation.patch
@@ -0,0 +1,36 @@
+--- configure.ac 2012-01-02 13:15:53.695067626 +0100
++++ configure.ac 2012-01-02 13:21:49.161623684 +0100
+@@ -1943,33 +1943,6 @@
+ AC_SUBST(MIME_TYPES)
+
+
+-#########################
+-# Disable deprecated APIs
+-#########################
+-
+-CPPFLAGS="${CPPFLAGS} -DGIMP_DISABLE_DEPRECATED -DBABL_DISABLE_DEPRECATED -DGSEAL_ENABLE"
+-
+-# Make sure not to disable deprecated APIs for unreleased versions.
+-# We must build without problems with future releases of libraries
+-# and disabling deprecated API risks breaking the build
+-
+-if test "x$have_glib_2_31" != "xyes"; then
+- CPPFLAGS="${CPPFLAGS} -DG_DISABLE_DEPRECATED"
+-fi
+-
+-if test "x$have_gtk_2_26" != "xyes"; then
+- CPPFLAGS="${CPPFLAGS} -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
+-fi
+-
+-if test "x$have_gdk_pixbuf_2_26" != "xyes"; then
+- CPPFLAGS="${CPPFLAGS} -DGDK_PIXBUF_DISABLE_DEPRECATED"
+-fi
+-
+-if test "x$have_pango_1_32" != "xyes"; then
+- CPPFLAGS="${CPPFLAGS} -DPANGO_DISABLE_DEPRECATED"
+-fi
+-
+-
+ ############################
+ # Require multihead safe API
+ ############################
diff --git a/media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch b/media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch
new file mode 100644
index 00000000..6f0c0c96
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.8.6-uclibc-execinfo.patch
@@ -0,0 +1,46 @@
+diff -uNr a/app/base/base-utils.c b/app/base/base-utils.c
+--- a/app/base/base-utils.c 2013-07-22 20:47:46.115387637 +0200
++++ b/app/base/base-utils.c 2013-07-22 20:49:11.034392213 +0200
+@@ -29,7 +29,7 @@
+ #include <process.h>
+ #endif
+
+-#ifdef G_OS_UNIX
++#if defined(G_OS_UNIX) && defined(HAVE_EXECINFO_H)
+ /* For get_backtrace() */
+ #include <stdlib.h>
+ #include <string.h>
+@@ -112,7 +112,7 @@
+ char *
+ get_backtrace (void)
+ {
+-#ifdef G_OS_UNIX
++#if defined(G_OS_UNIX) && defined(HAVE_EXECINFO_H)
+ void *functions[MAX_FUNC];
+ char **function_names;
+ int n_functions;
+diff -uNr a/config.h.in b/config.h.in
+--- a/config.h.in 2013-07-22 20:47:46.454387655 +0200
++++ b/config.h.in 2013-07-22 20:50:43.809397212 +0200
+@@ -26,6 +26,9 @@
+ /* always defined to indicate that i18n is enabled */
+ #undef ENABLE_NLS
+
++/* Define to 1 if you have the <execinfo.h> header file. */
++#undef HAVE_EXECINFO_H
++
+ /* The prefix for our gettext translation domains. */
+ #undef GETTEXT_PACKAGE
+
+diff -uNr a/configure.ac b/configure.ac
+--- a/configure.ac 2013-07-22 20:47:46.018387632 +0200
++++ b/configure.ac 2013-07-22 20:49:59.201394808 +0200
+@@ -416,7 +416,7 @@
+ AC_HEADER_SYS_WAIT
+ AC_HEADER_TIME
+
+-AC_CHECK_HEADERS(sys/param.h sys/time.h sys/times.h sys/wait.h unistd.h)
++AC_CHECK_HEADERS(execinfo.h sys/param.h sys/time.h sys/times.h sys/wait.h unistd.h)
+
+ AC_TYPE_PID_T
+ AC_FUNC_VPRINTF