summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2021-03-25 18:46:46 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2021-03-25 18:46:57 +0900
commit1b6977475fbe7843d10ce85ffa7689186e17a88e (patch)
treeaedd6dcbea90949c7fb5f3e0a351bf25aa214f42
parentLinux patch 5.11.9 (diff)
downloadlinux-patches-1b6977475fbe7843d10ce85ffa7689186e17a88e.tar.gz
linux-patches-1b6977475fbe7843d10ce85ffa7689186e17a88e.tar.bz2
linux-patches-1b6977475fbe7843d10ce85ffa7689186e17a88e.zip
linux patch 5.11.105.11-13
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
-rw-r--r--0000_README8
-rw-r--r--1009_linux-5.11.10.patch52
2 files changed, 60 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 93bf0805..a188a3c8 100644
--- a/0000_README
+++ b/0000_README
@@ -75,6 +75,14 @@ Patch: 1007_linux-5.11.8.patch
From: http://www.kernel.org
Desc: Linux 5.11.8
+Patch: 1008_linux-5.11.9.patch
+From: http://www.kernel.org
+Desc: Linux 5.11.9
+
+Patch: 1009_linux-5.11.10.patch
+From: http://www.kernel.org
+Desc: Linux 5.11.10
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1009_linux-5.11.10.patch b/1009_linux-5.11.10.patch
new file mode 100644
index 00000000..9d2fc8e0
--- /dev/null
+++ b/1009_linux-5.11.10.patch
@@ -0,0 +1,52 @@
+diff --git a/Makefile b/Makefile
+index 23403c8e08385..824d15c14be02 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 5
+ PATCHLEVEL = 11
+-SUBLEVEL = 9
++SUBLEVEL = 10
+ EXTRAVERSION =
+ NAME = 💕 Valentine's Day Edition 💕
+
+diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c
+index a76eb2c14e8c5..22073e77fdf9a 100644
+--- a/drivers/gpu/drm/ttm/ttm_bo.c
++++ b/drivers/gpu/drm/ttm/ttm_bo.c
+@@ -514,7 +514,7 @@ static void ttm_bo_release(struct kref *kref)
+ * shrinkers, now that they are queued for
+ * destruction.
+ */
+- if (WARN_ON(bo->pin_count)) {
++ if (bo->pin_count) {
+ bo->pin_count = 0;
+ ttm_bo_del_from_lru(bo);
+ ttm_bo_add_mem_to_lru(bo, &bo->mem);
+diff --git a/include/drm/ttm/ttm_bo_api.h b/include/drm/ttm/ttm_bo_api.h
+index b5bef31991967..2564e66e67d74 100644
+--- a/include/drm/ttm/ttm_bo_api.h
++++ b/include/drm/ttm/ttm_bo_api.h
+@@ -600,7 +600,6 @@ static inline bool ttm_bo_uses_embedded_gem_object(struct ttm_buffer_object *bo)
+ static inline void ttm_bo_pin(struct ttm_buffer_object *bo)
+ {
+ dma_resv_assert_held(bo->base.resv);
+- WARN_ON_ONCE(!kref_read(&bo->kref));
+ ++bo->pin_count;
+ }
+
+@@ -613,11 +612,8 @@ static inline void ttm_bo_pin(struct ttm_buffer_object *bo)
+ static inline void ttm_bo_unpin(struct ttm_buffer_object *bo)
+ {
+ dma_resv_assert_held(bo->base.resv);
+- WARN_ON_ONCE(!kref_read(&bo->kref));
+- if (bo->pin_count)
+- --bo->pin_count;
+- else
+- WARN_ON_ONCE(true);
++ WARN_ON_ONCE(!bo->pin_count);
++ --bo->pin_count;
+ }
+
+ int ttm_mem_evict_first(struct ttm_bo_device *bdev,