summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Task-Kensho/Task-Kensho-0.330.0.ebuild')
-rw-r--r--dev-perl/Task-Kensho/Task-Kensho-0.330.0.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/Task-Kensho/Task-Kensho-0.330.0.ebuild b/dev-perl/Task-Kensho/Task-Kensho-0.330.0.ebuild
new file mode 100644
index 000000000..ea92b0c43
--- /dev/null
+++ b/dev-perl/Task-Kensho/Task-Kensho-0.330.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=4
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.33
+inherit perl-module
+
+DESCRIPTION='A glimpse at an Enlightened Perl.'
+LICENSE=" || ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+basic-toolchain +testing +oop async webdev db crawl module-devel date
+config cli scripting xml +exceptions spreadsheet email scalability +logging"
+
+perl_meta_configure() {
+ # ExtUtils::MakeMaker 6.36 ( 6.360.0 )
+ echo \>=virtual/perl-ExtUtils-MakeMaker-6.360.0
+}
+perl_meta_build() {
+ # ExtUtils::MakeMaker 6.36 ( 6.360.0 )
+ echo \>=virtual/perl-ExtUtils-MakeMaker-6.360.0
+}
+
+feature() {
+ local name="$1";
+ shift;
+ echo "$name? (";
+ echo "$@";
+ echo ")";
+}
+sfeature() {
+ local name="$1";
+ local suffix="$2";
+ feature "$name" "dev-perl/Task-Kensho-${suffix}"
+}
+
+perl_meta_runtime() {
+ sfeature 'basic-toolchain' 'Toolchain';
+ sfeature 'exceptions' 'Exceptions';
+ sfeature 'testing' 'Testing';
+ sfeature 'oop' 'OOP';
+ sfeature 'async' 'Async';
+ sfeature 'xml' 'XML';
+ sfeature 'webdev' 'WebDev';
+ sfeature 'db' 'DBDev';
+ sfeature 'crawl' 'WebCrawling';
+ sfeature 'module-devel' 'ModuleDev';
+ sfeature 'scalability' 'Scalability';
+ sfeature 'date' 'Dates';
+ sfeature 'config' 'Config';
+ sfeature 'cli' 'CLI';
+ sfeature 'scripting' 'Hackery';
+ sfeature 'spreadsheet' 'ExcelCSV';
+ sfeature 'email' 'Email';
+ sfeature 'logging' 'Logging';
+}
+DEPEND="
+ $(perl_meta_configure)
+ $(perl_meta_build)
+ $(perl_meta_runtime)
+"
+RDEPEND="
+ $(perl_meta_runtime)
+"
+SRC_TEST="do"