summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-08-12 17:41:41 -0700
committerZac Medico <zmedico@gentoo.org>2017-08-12 17:43:40 -0700
commit84bf8d7ad50f46d8724b3c4232e387b506cf9a7a (patch)
tree3cf0641c69f24b1e45f05f8d8927a203bb2df6ca
parentemerge: add --autounmask-keep-keywords option (bug 622480) (diff)
downloadportage-84bf8d7ad50f46d8724b3c4232e387b506cf9a7a.tar.gz
portage-84bf8d7ad50f46d8724b3c4232e387b506cf9a7a.tar.bz2
portage-84bf8d7ad50f46d8724b3c4232e387b506cf9a7a.zip
setup.py: x_sdist default root owner for archive files
-rwxr-xr-xsetup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e47eb7390..e9b01d92b 100755
--- a/setup.py
+++ b/setup.py
@@ -528,11 +528,15 @@ class x_install_scripts(install_scripts):
class x_sdist(sdist):
- """ sdist defaulting to .tar.bz2 format """
+ """ sdist defaulting to .tar.bz2 format, and archive files owned by root """
def finalize_options(self):
if self.formats is None:
self.formats = ['bztar']
+ if self.owner is None:
+ self.owner = 'root'
+ if self.group is None:
+ self.group = 'root'
sdist.finalize_options(self)