aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/qt-core/qt-core-4.8.9999.ebuild')
-rw-r--r--x11-libs/qt-core/qt-core-4.8.9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11-libs/qt-core/qt-core-4.8.9999.ebuild b/x11-libs/qt-core/qt-core-4.8.9999.ebuild
index 18eb5d50..77229ec0 100644
--- a/x11-libs/qt-core/qt-core-4.8.9999.ebuild
+++ b/x11-libs/qt-core/qt-core-4.8.9999.ebuild
@@ -87,6 +87,13 @@ src_prepare() {
"${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix CXXFLAGS failed"
sed -i -e "s:LFLAGS.*=:LFLAGS=${LDFLAGS} :" \
"${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix LDFLAGS failed"
+
+ # bug #427782
+ sed -i -e "/^CPPFLAGS/s/-g//" \
+ "${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix CPPFLAGS failed"
+ sed -i -e "s/setBootstrapVariable QMAKE_CFLAGS_RELEASE/QMakeVar set QMAKE_CFLAGS_RELEASE/" \
+ -e "s/setBootstrapVariable QMAKE_CXXFLAGS_RELEASE/QMakeVar set QMAKE_CXXFLAGS_RELEASE/" \
+ "${S}/configure" || die "sed configure setBootstrapVariable failed"
}
src_configure() {