aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-03 16:17:05 +0100
committerJustin Lecher <jlec@gentoo.org>2015-03-03 16:17:05 +0100
commit9108d6ef60b7214bbffd62d1f335e1abe305659a (patch)
treeae88baaee5ffb848633ecb2bdae99653aefd7e7c
parentIMport to CVS (diff)
parentRemove myself as maintainer (diff)
downloadsci-9108d6ef60b7214bbffd62d1f335e1abe305659a.tar.gz
sci-9108d6ef60b7214bbffd62d1f335e1abe305659a.tar.bz2
sci-9108d6ef60b7214bbffd62d1f335e1abe305659a.zip
Merge remote-tracking branch 'github/master'
* github/master: Remove myself as maintainer dev-python/simplepam: Initial ebuild dev-python/jupyter-nbviewer: Correct license dev-python/jupyter-nbviewer: Initial ebuild dev-python/newrelic: Initial ebuild dev-python/jupyter-nbgrader: Update requirements dev-python/jupyter-nbgrader: Initial ebuild dev-util/amdapp: Minor fixes dev-util/amdapp-2.9.1: Remove trailing whitespace Add AMD-APPSDK license dev-util/amdapp-2.9.1: Version bump
-rw-r--r--dev-python/jupyter-nbgrader/ChangeLog9
-rw-r--r--dev-python/jupyter-nbgrader/jupyter-nbgrader-9999.ebuild32
-rw-r--r--dev-python/jupyter-nbgrader/metadata.xml8
-rw-r--r--dev-python/jupyter-nbviewer/ChangeLog9
-rw-r--r--dev-python/jupyter-nbviewer/jupyter-nbviewer-9999.ebuild35
-rw-r--r--dev-python/jupyter-nbviewer/metadata.xml10
-rw-r--r--dev-python/newrelic/ChangeLog9
-rw-r--r--dev-python/newrelic/Manifest1
-rw-r--r--dev-python/newrelic/metadata.xml9
-rw-r--r--dev-python/newrelic/newrelic-2.44.0.36.ebuild35
-rw-r--r--dev-python/simplepam/ChangeLog10
-rw-r--r--dev-python/simplepam/Manifest1
-rw-r--r--dev-python/simplepam/metadata.xml11
l---------dev-python/simplepam/simplepam-0.1.5.ebuild1
-rw-r--r--dev-python/simplepam/simplepam-9999.ebuild22
-rw-r--r--dev-util/amdapp/ChangeLog6
-rw-r--r--dev-util/amdapp/Manifest2
-rw-r--r--dev-util/amdapp/amdapp-2.9.1.ebuild83
-rw-r--r--licenses/AMD-APPSDK267
-rw-r--r--profiles/license_groups2
20 files changed, 561 insertions, 1 deletions
diff --git a/dev-python/jupyter-nbgrader/ChangeLog b/dev-python/jupyter-nbgrader/ChangeLog
new file mode 100644
index 000000000..16875733c
--- /dev/null
+++ b/dev-python/jupyter-nbgrader/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/jupyter-nbgrader
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*jupyter-nbgrader-9999 (03 Mar 2015)
+
+ 03 Mar 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +jupyter-nbgrader-9999.ebuild, +metadata.xml:
+ Initial ebuild
diff --git a/dev-python/jupyter-nbgrader/jupyter-nbgrader-9999.ebuild b/dev-python/jupyter-nbgrader/jupyter-nbgrader-9999.ebuild
new file mode 100644
index 000000000..b7f1f4a2a
--- /dev/null
+++ b/dev-python/jupyter-nbgrader/jupyter-nbgrader-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="nbgrader"
+
+DESCRIPTION="A system for assigning and grading notebooks"
+HOMEPAGE="http://jupyter.org"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jupyter/${MY_PN}.git git://github.com/jupyter/${MY_PN}.git"
+else
+ SRC_URI=""
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/ipython-3.0.0[notebook,${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
diff --git a/dev-python/jupyter-nbgrader/metadata.xml b/dev-python/jupyter-nbgrader/metadata.xml
new file mode 100644
index 000000000..2c6fd84fa
--- /dev/null
+++ b/dev-python/jupyter-nbgrader/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ A system for assigning and grading notebooks.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/jupyter-nbviewer/ChangeLog b/dev-python/jupyter-nbviewer/ChangeLog
new file mode 100644
index 000000000..059df275d
--- /dev/null
+++ b/dev-python/jupyter-nbviewer/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/jupyter-nbviewer
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*jupyter-nbviewer-9999 (03 Mar 2015)
+
+ 03 Mar 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +jupyter-nbviewer-9999.ebuild, +metadata.xml:
+ Initial ebuild
diff --git a/dev-python/jupyter-nbviewer/jupyter-nbviewer-9999.ebuild b/dev-python/jupyter-nbviewer/jupyter-nbviewer-9999.ebuild
new file mode 100644
index 000000000..a3031d4b7
--- /dev/null
+++ b/dev-python/jupyter-nbviewer/jupyter-nbviewer-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="nbviewer"
+
+DESCRIPTION="A system for assigning and grading notebooks"
+HOMEPAGE="http://jupyter.org"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jupyter/${MY_PN}.git git://github.com/jupyter/${MY_PN}.git"
+else
+ SRC_URI=""
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-4"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/ipython-3.0.0[notebook,${PYTHON_USEDEP}]
+ >=www-servers/tornado-3.1.1[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/newrelic[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/elasticsearch-py[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
diff --git a/dev-python/jupyter-nbviewer/metadata.xml b/dev-python/jupyter-nbviewer/metadata.xml
new file mode 100644
index 000000000..5ac942bc2
--- /dev/null
+++ b/dev-python/jupyter-nbviewer/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Jupyter nbviewer is the web application behind The Jupyter Notebook
+ Viewer, which is graciously hosted by Rackspace. Run this locally
+ to get most of the features of nbviewer on your own network.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/newrelic/ChangeLog b/dev-python/newrelic/ChangeLog
new file mode 100644
index 000000000..c2eb3a987
--- /dev/null
+++ b/dev-python/newrelic/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/newrelic
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*newrelic-2.44.0.36 (03 Mar 2015)
+
+ 03 Mar 2015; Marius Brehler <marbre@linux.sungazer.de> +metadata.xml,
+ +newrelic-2.44.0.36.ebuild:
+ Initial ebuild
diff --git a/dev-python/newrelic/Manifest b/dev-python/newrelic/Manifest
new file mode 100644
index 000000000..eb70f7c7d
--- /dev/null
+++ b/dev-python/newrelic/Manifest
@@ -0,0 +1 @@
+DIST newrelic-2.44.0.36.tar.gz 656605 SHA256 373d3af3e9f0c233932ddcf024f978eed3bd6ceaee9563aedb65c029f7f9b2b7 SHA512 2e9b7b6afd74c562c82813d0245822a194e151abf1e32827915b83677db811032711418ae2bd0c26b3ea4727323ca53d538862957d8cd07f7f6a2ce26630a682 WHIRLPOOL a36537b56d9e18c5143149821120296e3aae53094d9038bc0f2e4ac175820f7d6600c84d8cf17199d7a53e6dc93ef2e41885f17f2ace7de87c97a3100200149d
diff --git a/dev-python/newrelic/metadata.xml b/dev-python/newrelic/metadata.xml
new file mode 100644
index 000000000..b87287f06
--- /dev/null
+++ b/dev-python/newrelic/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Python agent for the New Relic web application performance
+ monitoring service.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/newrelic/newrelic-2.44.0.36.ebuild b/dev-python/newrelic/newrelic-2.44.0.36.ebuild
new file mode 100644
index 000000000..b34576f02
--- /dev/null
+++ b/dev-python/newrelic/newrelic-2.44.0.36.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="newrelic"
+
+DESCRIPTION="New Relic Python Agent"
+HOMEPAGE="http://newrelic.com/docs/python/new-relic-for-python"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="newrelic"
+SLOT="0"
+
+RDEPEND="
+ || (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pylons[${PYTHON_USEDEP}]
+ dev-python/pyramid[${PYTHON_USEDEP}]
+ )"
+ #|| (
+ # dev-python/cython[${PYTHON_USEDEP}]
+ # virtual/pypy
+ # virtual/pypy3
+ #)"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/simplepam/ChangeLog b/dev-python/simplepam/ChangeLog
new file mode 100644
index 000000000..1f3e6b271
--- /dev/null
+++ b/dev-python/simplepam/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/simplepam
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*simplepam-0.1.5 (03 Mar 2015)
+*simplepam-9999 (03 Mar 2015)
+
+ 03 Mar 2015; Marius Brehler <marbre@linux.sungazer.de> +metadata.xml,
+ +simplepam-0.1.5.ebuild, +simplepam-9999.ebuild:
+ Initial ebuild
diff --git a/dev-python/simplepam/Manifest b/dev-python/simplepam/Manifest
new file mode 100644
index 000000000..8d60e73c5
--- /dev/null
+++ b/dev-python/simplepam/Manifest
@@ -0,0 +1 @@
+DIST simplepam-0.1.5.tar.gz 2442 SHA256 9b4dd50da41a04dd6afff932b8b7e33c015af05beb3b3e5bcd323b64c2390a5f SHA512 489c7be29fc7cc16e29dc587c53c2fb94aeca3f08bc647772e3512e65c20a182f8244ca5127d5c04fd8aab57484ce79c2f0e214370f872f67734970da5acd414 WHIRLPOOL 70861a82fd10dc3a679ede5a2151c3597c8a07cbcc497ec030f99a74dec3826bbde4036870282080f61a91f2fce7736ab1308916192e21265e347a6243043354
diff --git a/dev-python/simplepam/metadata.xml b/dev-python/simplepam/metadata.xml
new file mode 100644
index 000000000..48fcc9381
--- /dev/null
+++ b/dev-python/simplepam/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ An interface to the Pluggable Authentication Modules (PAM) library,
+ written in pure python (using ctypes). This module provides an
+ authenticate function that allows the caller to authenticate a
+ given username / password against the PAM system.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/simplepam/simplepam-0.1.5.ebuild b/dev-python/simplepam/simplepam-0.1.5.ebuild
new file mode 120000
index 000000000..58783615d
--- /dev/null
+++ b/dev-python/simplepam/simplepam-0.1.5.ebuild
@@ -0,0 +1 @@
+simplepam-9999.ebuild \ No newline at end of file
diff --git a/dev-python/simplepam/simplepam-9999.ebuild b/dev-python/simplepam/simplepam-9999.ebuild
new file mode 100644
index 000000000..3694e0d0a
--- /dev/null
+++ b/dev-python/simplepam/simplepam-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python interface to the PAM library"
+HOMEPAGE="https://github.com/leonnnn/python3-simplepam"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leonnnn/python3-${PN}.git git://github.com/leonnnn/python3-${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
diff --git a/dev-util/amdapp/ChangeLog b/dev-util/amdapp/ChangeLog
index 8cf85ee02..0bf4083cf 100644
--- a/dev-util/amdapp/ChangeLog
+++ b/dev-util/amdapp/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*amdapp-2.9.1 (03 Mar 2015)
+
+ 03 Mar 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +amdapp-2.9.1.ebuild:
+ Version bump
+
18 Feb 2015; Justin Lecher <jlec@gentoo.org> -amdapp-2.8.ebuild,
amdapp-2.9.ebuild, metadata.xml:
dev-util/amdapp: fix SLOT operators; restrict fetch; drop old
diff --git a/dev-util/amdapp/Manifest b/dev-util/amdapp/Manifest
index d26fd78d0..465ae2531 100644
--- a/dev-util/amdapp/Manifest
+++ b/dev-util/amdapp/Manifest
@@ -1,2 +1,4 @@
+DIST AMD-APP-SDK-linux-v2.9-1.599.381-GA-x64.tar.bz2 126276109 SHA256 05337de10a4731a4f6b602849e8f0d2d0eec7bdd3637e94a8ea04aa332d26036 SHA512 41267cc5f020c6ddb6e60e6ed7141584aba4728c7f471d1b1244747fadfa175c811f7a0a273d95ddc07ac1b4fde8b64ad514a5eeee771e375b2d68f86eefcb50 WHIRLPOOL 172f3c9081569cbf5781a460b3a4ffcd9a2851cc0f47554fc9a1da5dcfd970fb774de46e8846c08331a166cac56687f13a661c2b74912e092b36d3b1d8829bc5
+DIST AMD-APP-SDK-linux-v2.9-1.599.381-GA-x86.tar.bz2 100512787 SHA256 a66bd935dfe871ecb0e940a4b5bc3bde310fca59a61bf9669f6b580d845c2db5 SHA512 59b3a12b51b22437fe0e743e7e0429455853f11c2a1b65fc91a63d6250dce1230460702287b1dc16a4672114d097a9e002ec93ed8c5063be2b070c242299aa5e WHIRLPOOL 56442f1a6bf03757b3a637f69c4083391540d523a74091318686da9ac8e342ff876285ce05ed3b6d21ce6e50072cdd6f0c239bee3550adafaff0cf2ae2065c6f
DIST AMD-APP-SDK-v2.9-lnx32.tgz 100284370 SHA256 86c0ebfd6a9037385d83d43237d986614f05ba035f50fd8d45e27c0d3c465646 SHA512 c0490223e5d8880bedf076fc6d7518507d59827caa29507cb0962b3ca4670f2a3a1d083019600ce838385d3116574887739f505cfdc01f5077a00ae584854bd0 WHIRLPOOL e6655eeeb47588d999585249f335571e427528d1a25878d6f16e47d37e1b30db5e1a1e13603f934ee20d76e5a3d16445c348169c3b6b6cbb81e5dfd543a43674
DIST AMD-APP-SDK-v2.9-lnx64.tgz 149825628 SHA256 6287d3d0700e563f2086188b1b2143a0e988a12c1dc22709b9a23d28b8ae83bb SHA512 b00d92b9e2ead559aa66120697a1dc15ecbc1c880eed99c2a7ed030f6cccce7434245a94aa6149e2ce2dc287cb9443700d7dbc8b3756c7420c0f54cc008065bb WHIRLPOOL b839c042a73251c0b774d1c2f6b968c166f4b74b4828a4f12709220e2c79783833979140127ec98a19b0883d7bf49d031088aeaeeb150855907f18378d5de0a9
diff --git a/dev-util/amdapp/amdapp-2.9.1.ebuild b/dev-util/amdapp/amdapp-2.9.1.ebuild
new file mode 100644
index 000000000..6e28cc4da
--- /dev/null
+++ b/dev-util/amdapp/amdapp-2.9.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit multilib unpacker versionator
+
+MY_V=$(get_version_component_range 1).$(get_version_component_range 2)
+
+X86_AT="AMD-APP-SDK-linux-v${MY_V}-1.599.381-GA-x86.tar.bz2"
+AMD64_AT="AMD-APP-SDK-linux-v${MY_V}-1.599.381-GA-x64.tar.bz2"
+
+MY_P_AMD64="AMD-APP-SDK-v${MY_V}-1.599.381-GA-linux64.sh"
+MY_P_AMD32="AMD-APP-SDK-v${MY_V}-1.599.381-GA-linux32.sh"
+
+DESCRIPTION="AMD Accelerated Parallel Processing (APP) SDK"
+HOMEPAGE="http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk"
+SRC_URI="
+ amd64? ( ${AMD64_AT} )
+ x86? ( ${X86_AT} )"
+LICENSE="AMD-APPSDK"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ app-admin/eselect-opengl
+ !<dev-util/amdstream-2.6
+ sys-devel/llvm
+ sys-devel/gcc
+ media-libs/mesa
+ media-libs/freeglut
+ virtual/opencl
+ examples? ( media-libs/glew )
+ app-admin/eselect-opencl"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ dev-util/patchelf
+ sys-apps/fakeroot"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "AMD doesn't provide direct download links. Please download"
+ einfo "${ARCHIVE} from ${HOMEPAGE}"
+}
+
+src_unpack() {
+ default
+
+ cd "${WORKDIR}" || die
+
+ if use amd64 || use amd64-linux ; then
+ unpacker ./${MY_P_AMD64}
+ else
+ unpacker ./${MY_P_X86}
+ fi
+}
+
+src_prepare() {
+ AMD_CL=usr/$(get_libdir)/OpenCL/vendors/amd/
+}
+
+src_compile() {
+ MAKEOPTS+=" -j1"
+ use examples && cd samples/opencl && emake
+}
+
+src_install() {
+ dodir /opt/AMDAPP
+ cp -R "${S}/"* "${ED}/opt/AMDAPP" || die "Install failed!"
+
+ dodir "${AMD_CL}"
+ dosym "/opt/AMDAPP/lib/`arch`/libOpenCL.so" "${AMD_CL}"
+ dosym "/opt/AMDAPP/lib/`arch`/libOpenCL.so.1" "${AMD_CL}"
+
+ #insinto /etc/OpenCL/vendors/
+ #doins ../etc/OpenCL/vendors/*
+}
diff --git a/licenses/AMD-APPSDK b/licenses/AMD-APPSDK
new file mode 100644
index 000000000..fece351dd
--- /dev/null
+++ b/licenses/AMD-APPSDK
@@ -0,0 +1,267 @@
+
+ SOFTWARE DEVELOPMENT KIT LICENSE AGREEMENT
+ (Linux APP SDK Installer)
+
+IMPORTANT-READ CAREFULLY: This is a legal agreement
+("Agreement") between you and Advanced Micro Devices, Inc.
+("AMD"). Your use of this AMD Software Development Kit, (the
+"SDK") including software, tools, utilities,
+Documentation, and to the extent provided hereunder, Libraries,
+Sample Code, header files, any related AMD materials, and
+updates thereto (collectively, "Licensed Materials"), are
+subject to the following terms and conditions.
+Do not use these Licensed Materials until you have carefully
+read the following terms and conditions. By downloading or
+using the Licensed Materials obtained herewith, you are
+expressly agreeing to all of the following
+terms:
+WARRANTIES, SUPPORT, RIGHTS, AND DAMAGES ARE DISCLAIMED AND/OR
+LIMITED BELOW, PLEASE READ ENTIRELY AND CAREFULLY. IF YOU DO
+NOT AGREE TO THE TERMS OF THIS AGREEMENT, DO NOT DOWNLOAD OR
+USE THE LICENSED MATERIALS OR ANY PORTION THEREOF. DOWNLOADING
+OR USING THE LICENSED MATERIALS OR ANY PORTION THEREOF
+CONSTITUTES YOUR ACCEPTANCE OF THIS AGREEMENT.
+
+1. Definitions.
+
+ 1.1. "Documentation" means install scripts and online or
+electronic documentation included with the Licensed
+Materials, or portions thereof.
+
+ 1.2. "Free Software License" means an open source or other
+license that requires, as a condition of use, modification or
+distribution, that any resulting software must be (a) disclosed
+or distributed in source code form; (b) licensed for the
+purpose of making derivative works; or (c) re-distributable at
+no charge.
+
+ 1.3. "Licensee Software" means any software developed or
+modified by you using the Licensed Materials, and which may
+include any Libraries, Sample Code and/or derivative works of
+Sample Code.
+
+ 1.4. "Intellectual Property Rights" means all copyrights,
+trademarks, trade secrets, patents, mask works, and all
+related, similar, or other intellectual property rights
+recognized in any jurisdiction worldwide, including all
+applications and registrations with respect thereto.
+
+ 1.5. "Libraries" means any run-times or other functionality
+provided in Object Code including but not limited to codecs and
+video processing libraries.
+
+ 1.6. "Object Code" means machine readable computer
+programming code files, which is not in a human readable form.
+
+ 1.7. "Sample Code" means the Source Code identified within
+the SDK as sample code.
+
+ 1.8. "Source Code" means computer programming code in human
+readable form and related system level documentation, including
+all comments, symbols and any procedural code such as job
+control language.
+
+2 License Grants.
+
+ 2.1 Internal Use. Subject to the terms and conditions of
+this Agreement, AMD hereby grants to you a non-exclusive, non-
+transferable, royalty-free copyright license solely for your
+internal use in developing Licensee Software for use with
+products based on or incorporating AMD products (a) to use the
+Licensed Materials, (b) to download, use, copy, and create
+derivative works of Sample Code in Source Code and to create
+compilations of same in Object Code form, and (c) to download,
+use and copy the Libraries.
+
+ 2.2 Restrictions. This Agreement does not grant you any
+rights, by license, implication or otherwise, in or to any
+associated materials or technology, except as is expressly
+provided herein. Furthermore, you acknowledge that except as
+expressly provided herein, the Licensed Materials provided by
+AMD hereunder are for your internal use only and you may not
+sell, transfer, assign, sublicense or distribute the Licensed
+Materials, in whole or in part, in any manner. Except as
+expressly specified in Section 2.1, you will have no right to
+make or have made derivatives of the Licensed Materials, to
+reverse engineer, modify, disassemble or to decompile the
+Licensed Materials, or otherwise reduce any part of the
+Licensed Materials to any human readable form. You will not
+use the Licensed Materials in applications intended to support
+or sustain life, or in which the failure of your product could
+create a situation where personal injury, death, or severe
+property or environmental damage may occur. You will not use or
+distribute with any Licensee Software any code that is licensed
+under a Free Software License. No portion of the Licensed
+Materials may in any event be distributed on a stand-alone
+basis or other than in the form of Licensee Software. You must
+not alter or remove any copyright, trademark or patent notice
+in the Licensed Materials. You must reproduce all AMD
+trademark and/or copyright notices on any derivative work that
+incorporates Sample Code or Libraries. You may not use AMD's
+trademarks in the Licensee Software name or advertising in a
+way that suggests the Licensee Software comes from or is
+endorsed by AMD.
+
+ 2.3 Third Party Materials. Together with the Licensed
+Materials, AMD may include third party technologies (e.g. third
+party libraries) for which you must obtain licenses from
+parties other than AMD. You agree that AMD has not obtained or
+conveyed to you, and that you shall be responsible for
+obtaining, Intellectual Property Rights to use and/or
+distribute the applicable, underlying Intellectual Property
+Rights related to the third party technologies. These third
+party technologies are not licensed as part of the Licensed
+Materials and are not licensed under this Agreement.
+
+ 2.4 Other AMD Software Components. The Licensed
+Materials may be accompanied by AMD software components (e.g.
+libraries, sample code) which are licensed to you under the
+terms and conditions of their respective licenses located in
+the directory with the software component.
+
+ 2.5 Feedback. You have no obligation to give AMD any
+suggestions, comments or other feedback ("Feedback") relating
+to the Licensed Materials. However, AMD may use and include
+any Feedback that you voluntarily provide to improve the
+Licensed Materials or other AMD products and technologies.
+Accordingly, if you provide Feedback, you grant AMD and its
+affiliates and subsidiaries a worldwide, non-exclusive,
+irrevocable, royalty-free, perpetual license to use, reproduce,
+license, sublicense, distribute, make, have made, sell and
+otherwise commercialize the Feedback in the Licensed Materials
+or other AMD technologies. You further agree not to provide
+any Feedback that (a) you know is subject to any patent,
+copyright or other intellectual property claim or right of any
+third party; or (b) is subject to a Free Software License.
+
+3 Ownership and Copyright Notices. The Licensed Materials are
+owned or licensed by AMD and are protected by United States and
+foreign intellectual property laws and international treaty
+provisions. All title and copyrights in and to the Licensed
+Materials, all copies thereof (in whole or in part, and in any
+form), and all rights therein will remain vested in AMD.
+Except as expressly provided herein, AMD does not grant any
+express or implied right to you under AMD patents, copyrights,
+trademarks, or trade secrets. You agree the Licensed Materials
+are licensed, not sold by AMD.
+
+4 Support. You will not be entitled to any support of any kind
+from AMD or AMD's licensors. Furthermore, you will be solely
+responsible for providing support to your end users for the
+Licensee Software distributed by you or your
+products. AMD may, in its sole discretion, provide to you
+updates to the Licensed Materials.
+
+5 Warranty, Limitations of Liability and Indemnification.
+
+ 5.1 THE LICENSED MATERIALS ARE PROVIDED "AS IS," WITH ALL
+FAULTS, AND WITHOUT WARRANTY OF ANY KIND. AMD DISCLAIMS ALL
+WARRANTIES, EXPRESS, IMPLIED, OR STATUTORY, INCLUDING BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS
+FOR A PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT. AMD
+DOES NOT WARRANT THAT THE LICENSED MATERIALS ARE ERROR FREE OR
+THAT THE LICENSED MATERIALS WILL RUN CONTINUOUSLY.
+
+ 5.2 AMD WILL NOT, UNDER ANY CIRCUMSTANCES, BE LIABLE TO
+YOU FOR CONSEQUENTIAL, INCIDENTAL, PUNITIVE OR SPECIAL DAMAGES,
+INCLUDING BUT NOT LIMITED TO, LOSS OF USE, DATA OR PROFITS,
+ARISING FROM THIS AGREEMENT, EVEN IF AMD HAS BEEN APPRISED OF
+THE LIKELIHOOD OF SUCH DAMAGES. In no event will AMD's total
+liability to you for all damages, losses, and causes of action
+(whether in contract, tort (including negligence) or otherwise)
+exceed the amount of $100 USD.
+
+ 5.3 You agree to defend, indemnify and hold harmless AMD
+and its licensors, and any of their directors, officers,
+employees, affiliates or agents, from and against any and all
+loss, damage, liability and other expenses (including
+reasonable attorneys' fees), resulting from (a) your improper
+use of the Licensed Materials or (b) use of Licensee Software.
+
+6 Termination. Either party may terminate this Agreement upon
+thirty (30) days prior written notice to the other party. This
+Agreement will terminate immediately without notice from AMD or
+judicial resolution if you fail to comply
+with any provisions of this Agreement or upon AMD's written
+request for return of the Licensed Materials. Upon termination
+of this Agreement, you will cease using the Licensed Materials.
+Termination of this Agreement will have no effect on any sub-
+licenses properly granted by you to end users under Section 2,
+which sub-licenses will survive in accordance with their terms.
+
+7 Survival. Notwithstanding the foregoing, Sections 2.2, 2.3,
+2.4, 2.5, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12 and 13 will survive
+any expiration or termination of this Agreement, until by their
+own terms they are fulfilled.
+
+8 Export Restrictions. You shall adhere to all applicable
+U.S., European, and other export laws, including but not
+limited to the U.S. Export Administration Regulations ("EAR"),
+(15 C.F.R. Sections 730 through 774), and E.U. Council
+Regulation (EC) No 428/2009 of 5 May 2009. Further, pursuant
+to Section 740.6 of the EAR, you hereby certify that, except
+pursuant to a license granted by the United States Department
+of Commerce Bureau of Industry and Security or as otherwise
+permitted pursuant to a License Exception under the EAR, you
+will not (1) export, re-export or release to a national of a
+country in Country Groups D:1, E:1 or E:2 any restricted
+technology, software, or source code you receive from AMD, or
+(2) export to Country Groups D:1, E:1 or E:2 the direct product
+of such technology or software, if such foreign produced direct
+product is subject to national security controls as identified
+on the Commerce Control List (currently found in Supplement 1
+to Part 774 of EAR). For the most current Country Group
+listings, or for additional information about the EAR or your
+obligations under those regulations, please refer to the U.S.
+Bureau of Industry and Security's website at
+http://www.bis.doc.gov/.
+
+9. U.S. Government Restricted Rights. The Licensed Materials
+are provided with "RESTRICTED RIGHTS." Use, duplication or
+disclosure by the Government is subject to restrictions as set
+forth in FAR 52.227-14 and DFAR 252.227-7013, et seq., or its
+successor. Use of the Licensed Materials by the Government
+constitutes acknowledgement of AMD's proprietary rights in
+them.
+
+10. Governing Law. This Agreement will be governed under the
+laws of Texas, excluding the conflicts of law rules, and is
+deemed to have been executed and performed in Austin, Texas.
+
+11. Equitable Remedies. You acknowledge that your breach of
+this Agreement may cause irreparable damage to AMD and agree
+that AMD shall be entitled to seek injunctive relief under this
+Agreement, as well as such further relief as may be granted by
+a court of competent jurisdiction.
+
+12. General. You may not assign this Agreement. Any attempted
+assignment by you will be null and void. The parties do not
+intend that any agency or partnership relationship be created
+between them by this Agreement. Each
+provision of this Agreement shall be interpreted in such a
+manner as to be effective and valid under applicable law.
+However, in the event that any provision of this Agreement
+becomes or is declared unenforceable by any court of
+competent jurisdiction, such provision shall be deemed deleted
+and the remainder of this Agreement shall remain in full force
+and effect
+
+13. Entire Agreement. This Agreement sets forth the entire
+agreement and understanding between the parties and supersedes
+and merges all prior and contemporaneous oral and/or written
+agreements, discussions and
+understandings concerning the subject matter hereof. This
+Agreement may not be modified except by a written instrument
+executed by the parties. No waiver or modification of any
+provision of this Agreement shall be binding unless made in
+writing and signed by an authorized representative of each
+party.
+
+If you agree to abide by the terms and conditions of this
+Agreement, please press "Accept." If you do not agree to abide
+by the terms and conditions of this Agreement, press "Decline"
+and you may not use or access the Licensed
+Materials.
+
+By clicking accept, you confirm that you are neither a resident
+nor a national of Cuba, Iran, North Korea, the Sudan or Syria.
diff --git a/profiles/license_groups b/profiles/license_groups
index a2ba71db5..86a807021 100644
--- a/profiles/license_groups
+++ b/profiles/license_groups
@@ -1 +1 @@
-EULA ACML-EULA NVIDIA-gdk
+EULA ACML-EULA AMD-APPSDK NVIDIA-gdk