summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-03-20 07:45:04 +0800
committerYixun Lan <dlan@gentoo.org>2014-03-20 07:45:04 +0800
commit35aac8af4c1501571583e1faa13f6ce845e27458 (patch)
tree4761979170fd213355de6814c4b94184d3e97ffc
parentapp-emulation/xen-tools: fix deps, remove libaio for arm (diff)
downloadvirtualization-35aac8af4c1501571583e1faa13f6ce845e27458.tar.gz
virtualization-35aac8af4c1501571583e1faa13f6ce845e27458.tar.bz2
virtualization-35aac8af4c1501571583e1faa13f6ce845e27458.zip
app-emulation/xen: amend efi patch
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-emulation/xen/files/xen-4.4-efi.patch23
-rw-r--r--app-emulation/xen/xen-4.4.0.ebuild2
2 files changed, 24 insertions, 1 deletions
diff --git a/app-emulation/xen/files/xen-4.4-efi.patch b/app-emulation/xen/files/xen-4.4-efi.patch
new file mode 100644
index 0000000..9213ade
--- /dev/null
+++ b/app-emulation/xen/files/xen-4.4-efi.patch
@@ -0,0 +1,23 @@
+diff --git a/xen/Makefile b/xen/Makefile
+index 39839a3..d2603f0 100644
+--- a/xen/Makefile
++++ b/xen/Makefile
+@@ -38,9 +38,15 @@ _install: Z=$(CONFIG_XEN_INSTALL_SUFFIX)
+ _install: $(TARGET)$(CONFIG_XEN_INSTALL_SUFFIX)
+ [ -d $(D)/boot ] || $(INSTALL_DIR) $(D)/boot
+ $(INSTALL_DATA) $(TARGET)$(Z) $(D)/boot/$(T)-$(XEN_FULLVERSION)$(Z)
+- ln -f -s $(T)-$(XEN_FULLVERSION)$(Z) $(D)/boot/$(T)-$(XEN_VERSION).$(XEN_SUBVERSION)$(Z)
+- ln -f -s $(T)-$(XEN_FULLVERSION)$(Z) $(D)/boot/$(T)-$(XEN_VERSION)$(Z)
+- ln -f -s $(T)-$(XEN_FULLVERSION)$(Z) $(D)/boot/$(T)$(Z)
++ if [ 'x$(EFI_VENDOR)' == 'x' ]; then \
++ ln -f -s $(T)-$(XEN_FULLVERSION)$(Z) $(D)/boot/$(T)-$(XEN_VERSION).$(XEN_SUBVERSION)$(Z); \
++ ln -f -s $(T)-$(XEN_FULLVERSION)$(Z) $(D)/boot/$(T)-$(XEN_VERSION)$(Z);\
++ ln -f -s $(T)-$(XEN_FULLVERSION)$(Z) $(D)/boot/$(T)$(Z); \
++ else \
++ $(INSTALL_DATA) $(TARGET)$(Z) $(D)/boot/$(T)-$(XEN_VERSION).$(XEN_SUBVERSION)$(Z); \
++ $(INSTALL_DATA) $(TARGET)$(Z) $(D)/boot/$(T)-$(XEN_VERSION)$(Z);\
++ $(INSTALL_DATA) $(TARGET)$(Z) $(D)/boot/$(T)$(Z); \
++ fi; \
+ $(INSTALL_DATA) $(TARGET)-syms $(D)/boot/$(T)-syms-$(XEN_FULLVERSION)
+ if [ -r $(TARGET).efi -a -n '$(EFI_DIR)' ]; then \
+ [ -d $(D)$(EFI_DIR) ] || $(INSTALL_DIR) $(D)$(EFI_DIR); \
diff --git a/app-emulation/xen/xen-4.4.0.ebuild b/app-emulation/xen/xen-4.4.0.ebuild
index 01c2efb..f311c3d 100644
--- a/app-emulation/xen/xen-4.4.0.ebuild
+++ b/app-emulation/xen/xen-4.4.0.ebuild
@@ -95,7 +95,7 @@ src_prepare() {
sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
if use efi; then
- epatch "${FILESDIR}"/${PN}-4.2-efi.patch
+ epatch "${FILESDIR}"/${PN}-4.4-efi.patch
export EFI_VENDOR="gentoo"
export EFI_MOUNTPOINT="boot"
fi