summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-16 15:28:58 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-16 15:29:39 -0500
commit073fa98637f186287e871249302badd0893f5f15 (patch)
tree522f703ce3ac2d5630ea31a64eaa812799145105
parentapp-misc/livecd-tools: sync live ebuild (diff)
downloadgentoo-073fa98637f186287e871249302badd0893f5f15.tar.gz
gentoo-073fa98637f186287e871249302badd0893f5f15.tar.bz2
gentoo-073fa98637f186287e871249302badd0893f5f15.zip
sys-apps/memtest86: add fixes from memtest86+ #568292
This fixes building w/gcc-5 and parallel build races.
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.7-io-extern-inline.patch29
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch16
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.7-reboot-def.patch13
-rw-r--r--sys-apps/memtest86/memtest86-4.3.7.ebuild3
4 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/memtest86/files/memtest86-4.3.7-io-extern-inline.patch b/sys-apps/memtest86/files/memtest86-4.3.7-io-extern-inline.patch
new file mode 100644
index 000000000000..3e6754d112b3
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.7-io-extern-inline.patch
@@ -0,0 +1,29 @@
+the meaning of extern inline changed between standards. use static inline
+for these tiny I/O functions everywhere to keep things simple.
+
+--- a/io.h
++++ b/io.h
+@@ -31,6 +31,6 @@
+ */
+
+ #define __OUT1(s,x) \
+-extern inline void __out##s(unsigned x value, unsigned short port) {
++static inline void __out##s(unsigned x value, unsigned short port) {
+
+ #define __OUT2(s,s1,s2) \
+@@ -43,6 +43,6 @@
+ __OUT1(s##c_p,x) __OUT2(s,s1,"") : : "a" (value), "id" (port)); SLOW_DOWN_IO; }
+
+ #define __IN1(s) \
+-extern inline RETURN_TYPE __in##s(unsigned short port) { RETURN_TYPE _v;
++static inline RETURN_TYPE __in##s(unsigned short port) { RETURN_TYPE _v;
+
+ #define __IN2(s,s1,s2) \
+@@ -55,6 +55,6 @@
+ __IN1(s##c_p) __IN2(s,s1,"") : "=a" (_v) : "id" (port) ,##i ); SLOW_DOWN_IO; return _v; }
+
+ #define __OUTS(s) \
+-extern inline void outs##s(unsigned short port, const void * addr, unsigned long count) \
++static inline void outs##s(unsigned short port, const void * addr, unsigned long count) \
+ { __asm__ __volatile__ ("cld ; rep ; outs" #s \
+ : "=S" (addr), "=c" (count) : "d" (port),"0" (addr),"1" (count)); }
diff --git a/sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch b/sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch
new file mode 100644
index 000000000000..cd8fc66ba094
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.7-no-clean.patch
@@ -0,0 +1,16 @@
+don't run the clean target when building all as we run into parallel races:
+ - memtest kicks off building of a bunch of .o files
+ - clean runs in parallel which runs `rm` and deletes some of the new .o
+ - memtest goes to link and fails because objects are missing
+
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+
+-all: clean memtest.bin memtest
++all: memtest.bin memtest
+
+ # Link it statically once so I know I don't have undefined
+ # symbols and then link it dynamically so I have full
diff --git a/sys-apps/memtest86/files/memtest86-4.3.7-reboot-def.patch b/sys-apps/memtest86/files/memtest86-4.3.7-reboot-def.patch
new file mode 100644
index 000000000000..be9e35347fe7
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.7-reboot-def.patch
@@ -0,0 +1,13 @@
+the reboot func is used elsewhere, so don't mark it inline
+
+--- a/lib.c
++++ b/lib.c
+@@ -33,7 +33,7 @@ struct ascii_map_str {
+ int keycode;
+ };
+
+-inline void reboot(void)
++void reboot(void)
+ {
+
+ /* tell the BIOS to do a cold start */
diff --git a/sys-apps/memtest86/memtest86-4.3.7.ebuild b/sys-apps/memtest86/memtest86-4.3.7.ebuild
index 7a543827d99a..fd0ec262d63f 100644
--- a/sys-apps/memtest86/memtest86-4.3.7.ebuild
+++ b/sys-apps/memtest86/memtest86-4.3.7.ebuild
@@ -20,6 +20,9 @@ BOOTDIR=/boot/memtest86
src_prepare() {
epatch "${FILESDIR}"/${PN}-4.3.3-build-nopie.patch #66630 + #206726
+ epatch "${FILESDIR}"/${PN}-4.3.7-io-extern-inline.patch #548312 #568292
+ epatch "${FILESDIR}"/${PN}-4.3.7-reboot-def.patch #548312 #568292
+ epatch "${FILESDIR}"/${PN}-4.3.7-no-clean.patch #557890
sed -i -e 's,0x10000,0x100000,' memtest.lds || die