summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-24 15:16:24 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-24 15:16:40 -0500
commit3cc0db0c9bd107846e399865c55f5ae5c47031da (patch)
tree55b94dbd007ae62d23618ab63707459c1d29d6fa
parentx11-wm/enlightenment: update e16 ebuilds to EAPI=5 (diff)
downloadgentoo-3cc0db0c9bd107846e399865c55f5ae5c47031da.tar.gz
gentoo-3cc0db0c9bd107846e399865c55f5ae5c47031da.tar.bz2
gentoo-3cc0db0c9bd107846e399865c55f5ae5c47031da.zip
media-libs/imlib2: add fix from upstream #563732
-rw-r--r--media-libs/imlib2/files/imlib2-1.4.7-headers.patch26
-rw-r--r--media-libs/imlib2/imlib2-1.4.7.ebuild7
2 files changed, 32 insertions, 1 deletions
diff --git a/media-libs/imlib2/files/imlib2-1.4.7-headers.patch b/media-libs/imlib2/files/imlib2-1.4.7-headers.patch
new file mode 100644
index 000000000000..d2fba06c3ba2
--- /dev/null
+++ b/media-libs/imlib2/files/imlib2-1.4.7-headers.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/563732
+
+From 521573be219f27c7bfebb57d5b0b994fdb316721 Mon Sep 17 00:00:00 2001
+From: Chloe Kudryavtsev <chloe.kudryavtsev@gmail.com>
+Date: Sat, 24 Oct 2015 23:38:53 -0400
+Subject: [PATCH] add time.h include to common.h for time_t
+
+---
+ src/lib/common.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/lib/common.h b/src/lib/common.h
+index 798965f..9053826 100644
+--- a/src/lib/common.h
++++ b/src/lib/common.h
+@@ -9,6 +9,7 @@
+ #include <config.h>
+ #include <string.h>
+ #include <math.h>
++#include <time.h>
+ #ifdef WITH_DMALLOC
+ #include <dmalloc.h>
+ #endif
+--
+2.6.2
+
diff --git a/media-libs/imlib2/imlib2-1.4.7.ebuild b/media-libs/imlib2/imlib2-1.4.7.ebuild
index 4af11591bead..f2b3f29ecf3e 100644
--- a/media-libs/imlib2/imlib2-1.4.7.ebuild
+++ b/media-libs/imlib2/imlib2-1.4.7.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} != "9999" ]] ; then
EKEY_STATE="snap"
fi
-inherit enlightenment toolchain-funcs multilib-minimal
+inherit enlightenment toolchain-funcs multilib-minimal eutils
DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
HOMEPAGE="https://www.enlightenment.org/"
@@ -37,6 +37,11 @@ DEPEND="${RDEPEND}
>=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
)"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-headers.patch #563732
+ enlightenment_src_prepare
+}
+
multilib_src_configure() {
# imlib2 has diff configure options for x86/amd64 mmx
if [[ $(tc-arch) == amd64 ]]; then