summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-embedded/lm4tools/lm4tools-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-embedded/lm4tools/lm4tools-9999.ebuild b/dev-embedded/lm4tools/lm4tools-9999.ebuild
index ece5beb..81789f2 100644
--- a/dev-embedded/lm4tools/lm4tools-9999.ebuild
+++ b/dev-embedded/lm4tools/lm4tools-9999.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-EGIT_REPO_URI="https://github.com/utzig/lm4tools.git"
-
-inherit eutils toolchain-funcs git-r3
+inherit toolchain-funcs git-r3
DESCRIPTION="Provides lm4flash and lmicdiusb for developing on the TI Stellaris Launchpad"
HOMEPAGE="https://github.com/utzig/lm4tools"
+EGIT_REPO_URI="https://github.com/utzig/lm4tools.git"
LICENSE="GPL-2+ MIT"
SLOT="0"
RDEPEND="virtual/libusb:1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
src_prepare () {
sed -e "s:gcc:$(tc-getCC):" -i lm4flash/Makefile || die