summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/calyp/calyp-1.0.0-r1.ebuild')
-rw-r--r--media-video/calyp/calyp-1.0.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-video/calyp/calyp-1.0.0-r1.ebuild b/media-video/calyp/calyp-1.0.0-r1.ebuild
new file mode 100644
index 0000000..7f81e46
--- /dev/null
+++ b/media-video/calyp/calyp-1.0.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils cmake
+
+DESCRIPTION="Calyp is an open-source QT based raw video player"
+HOMEPAGE="https://github.com/pixlra/calyp"
+SRC_URI="https://github.com/pixlra/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT=0
+KEYWORDS="~amd64"
+
+X86_CPU_FEATURES="cpu_flags_x86_sse"
+IUSE="+qt5 ffmpeg opencv -static-libs $X86_CPU_FEATURES"
+
+DEPEND="
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+ ffmpeg? ( media-video/ffmpeg )
+ opencv? ( media-libs/opencv )
+"
+
+RDEPEND="
+ !media-video/playuver
+ ${DEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SSE=$(usex cpu_flags_x86_sse)
+ -DUSE_FFMPEG=$(usex ffmpeg)
+ -DUSE_OPENCV=$(usex opencv)
+ -DUSE_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}