summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoranna 'ruda <chaotic.anna@gmail.com>2011-01-06 13:47:25 +0000
committeranna 'ruda <chaotic.anna@gmail.com>2011-01-06 13:47:25 +0000
commit35242b67afc99a21f577c65e4e2f5bec9ff457af (patch)
tree7838edf5f1f3132dfcf886eee7000d72dd4262c2
parentLive ebuilds for dzen and gajim; ebuild for wmname; package.mask fix for (diff)
downloadeatnumber1-35242b67afc99a21f577c65e4e2f5bec9ff457af.tar.gz
eatnumber1-35242b67afc99a21f577c65e4e2f5bec9ff457af.tar.bz2
eatnumber1-35242b67afc99a21f577c65e4e2f5bec9ff457af.zip
tkpath ebuild; idea-community version bump; idea-ultimate ebuild
-rw-r--r--dev-tcltk/tkpath/Manifest2
-rw-r--r--dev-tcltk/tkpath/files/man-pages.patch27
-rw-r--r--dev-tcltk/tkpath/tkpath-9999.ebuild55
-rw-r--r--dev-util/idea-community/Manifest4
-rw-r--r--dev-util/idea-community/idea-community-10.0.1.99.32.ebuild37
-rw-r--r--dev-util/idea-community/idea-community-9.0.1.93.94.ebuild2
-rw-r--r--dev-util/idea-ultimate/Manifest2
-rw-r--r--dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild37
-rw-r--r--layman-local.cfg2
9 files changed, 166 insertions, 2 deletions
diff --git a/dev-tcltk/tkpath/Manifest b/dev-tcltk/tkpath/Manifest
new file mode 100644
index 0000000..9298a0a
--- /dev/null
+++ b/dev-tcltk/tkpath/Manifest
@@ -0,0 +1,2 @@
+AUX man-pages.patch 908 RMD160 1f2a0b1ebce3a55aad6f4c86a98726ce7e648ce1 SHA1 e5b5a5c965578bb346c775bfaaca46f8b29cc26c SHA256 83b6ccdeaec481db0386949128f2613740886065ddb17f96460ce4190ceaae87
+EBUILD tkpath-9999.ebuild 978 RMD160 c7e6b8c789840a29aa408d4a1bddc5631f08fe5b SHA1 ff0622106908c5fb1ff9255e1dc4bca39c5f848e SHA256 d51c077a180c59fcde1b47d1902912c32d8b725720be619637bd29e3703f6283
diff --git a/dev-tcltk/tkpath/files/man-pages.patch b/dev-tcltk/tkpath/files/man-pages.patch
new file mode 100644
index 0000000..5e135c1
--- /dev/null
+++ b/dev-tcltk/tkpath/files/man-pages.patch
@@ -0,0 +1,27 @@
+*** Makefile.in 2009-04-01 22:45:45.000000000 +0000
+--- Makefile.in- 2011-01-06 01:12:26.000000000 +0000
+***************
+*** 224,237 ****
+ # directory.
+ #========================================================================
+
+ install-doc: doc
+- @mkdir -p $(DESTDIR)$(mandir)/mann
+- @echo "Installing documentation in $(DESTDIR)$(mandir)"
+- @list='$(srcdir)/doc/*.n'; for i in $$list; do \
+- echo "Installing $$i"; \
+- rm -f $(DESTDIR)$(mandir)/mann/`basename $$i`; \
+- $(INSTALL_DATA) $$i $(DESTDIR)$(mandir)/mann ; \
+- done
+
+ # Piping to cat is necessary on Windows to see the output, and
+ # harmless on Unix
+--- 224,231 ----
+ # directory.
+ #========================================================================
+
++ # no-op target as package has no manual pages
+ install-doc: doc
+
+ # Piping to cat is necessary on Windows to see the output, and
+ # harmless on Unix
diff --git a/dev-tcltk/tkpath/tkpath-9999.ebuild b/dev-tcltk/tkpath/tkpath-9999.ebuild
new file mode 100644
index 0000000..96c1e2b
--- /dev/null
+++ b/dev-tcltk/tkpath/tkpath-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cvs
+
+DESCRIPTION="Tkpath implements path drawing modelled after its SVG counterpart"
+HOMEPAGE="http://tclbitprint.sourceforge.net/"
+SRC_URI=""
+
+ECVS_SERVER="tclbitprint.cvs.sourceforge.net:/cvsroot/tclbitprint"
+ECVS_MODULE="tkpath"
+ECVS_USER="anonymous"
+ECVS_PASS=""
+ECVS_CVS_OPTIONS="-z3 -d"
+ECVS_AUTH="pserver"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="64bit threads"
+
+DEPEND="
+ dev-lang/tk
+ x11-libs/cairo"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/man-pages.patch"
+}
+
+src_configure(){
+ cd "${WORKDIR}/${PN}"
+ econf \
+ $(use_enable symbols) \
+ $(use_enable 64bit) \
+ $(use_enable threads)
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog doc/README.txt || die
+ dodir /usr/share/${PN}/demos
+ insinto /usr/share/${PN}/demos
+ doins demos/*
+}
+
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index f886785..470859a 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,4 @@
-EBUILD idea-community-9.0.1.93.94.ebuild 947 RMD160 a38065bcb92247708c298ffee2fd868a32f3e3ec SHA1 ec8d2b70b7d9f865f845956a1e7e0d1d3b6ab4b0 SHA256 e359f76099d4603f9e322edfa4965313126f3d230d2a10b18139622c1f774a08
+DIST ideaIC-10.0.1.tar.gz 82969729 RMD160 4c781e45b8836414751f12e9ed3090da4aa581b7 SHA1 b58e39e8e0bbef000ab5f4c01dbc8d7c68cd95b9 SHA256 eab3d0ea306faf597a27406c1e242100cc07422bdcb1521f72b37634e6d20606
DIST ideaIC-9.0.1.tar.gz 68263881 RMD160 e3bc3395ad23c29eac9d631c6fc4705481191296 SHA1 39971aa471dbeca1a0637cf868a986d7429439d4 SHA256 9d3a7aafe1103078e9fc4d5a67475be1702acd5df802e256501de3d2c7b96c6e
+EBUILD idea-community-10.0.1.99.32.ebuild 982 RMD160 f6d2f2f36d277a43fb9b358682b5a9491ba7d806 SHA1 c9b750e2a4e8a9198f91f69c58489490a1f0660a SHA256 bffffc90bc95171eb70b18f2420fb617401027dadb460fd307cb54760b72b5d2
+EBUILD idea-community-9.0.1.93.94.ebuild 982 RMD160 f6d2f2f36d277a43fb9b358682b5a9491ba7d806 SHA1 c9b750e2a4e8a9198f91f69c58489490a1f0660a SHA256 bffffc90bc95171eb70b18f2420fb617401027dadb460fd307cb54760b72b5d2
diff --git a/dev-util/idea-community/idea-community-10.0.1.99.32.ebuild b/dev-util/idea-community/idea-community-10.0.1.99.32.ebuild
new file mode 100644
index 0000000..70c02d6
--- /dev/null
+++ b/dev-util/idea-community/idea-community-10.0.1.99.32.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils versionator
+
+SLOT="$(get_major_version)"
+RDEPEND=">=virtual/jdk-1.6"
+
+MY_PV="$(get_version_component_range 4-5)"
+MY_PN="idea"
+
+RESTRICT="strip"
+QA_TEXTRELS="opt/${P}/bin/libbreakgen.so"
+
+DESCRIPTION="IntelliJ IDEA is an intelligent Java IDE"
+HOMEPAGE="http://jetbrains.com/idea/"
+SRC_URI="http://download.jetbrains.com/${MY_PN}/${MY_PN}IC-$(get_version_component_range 1-3).tar.gz"
+LICENSE="IntelliJ-IDEA"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+S="${WORKDIR}/${MY_PN}-IC-${MY_PV}"
+
+RDEPEND="!dev-util/idea-ultimate"
+
+src_install() {
+ local dir="/opt/${P}"
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}/bin/${MY_PN}.sh"
+ local exe=${MY_PN}-${SLOT}
+ local icon=${exe}.png
+ newicon "bin/${MY_PN}32.png" ${icon}
+ dodir /usr/bin
+ make_wrapper "$exe" "/opt/${P}/bin/${MY_PN}.sh"
+ make_desktop_entry ${exe} "IntelliJ IDEA ${PV}" ${icon} "Development;IDE"
+}
diff --git a/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild b/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild
index 2bf75fa..70c02d6 100644
--- a/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild
+++ b/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild
@@ -21,6 +21,8 @@ IUSE=""
KEYWORDS="~x86 ~amd64"
S="${WORKDIR}/${MY_PN}-IC-${MY_PV}"
+RDEPEND="!dev-util/idea-ultimate"
+
src_install() {
local dir="/opt/${P}"
insinto "${dir}"
diff --git a/dev-util/idea-ultimate/Manifest b/dev-util/idea-ultimate/Manifest
new file mode 100644
index 0000000..d2f5a18
--- /dev/null
+++ b/dev-util/idea-ultimate/Manifest
@@ -0,0 +1,2 @@
+DIST ideaIU-10.0.1.tar.gz 157460582 RMD160 d24eda685d6b8ed7764c8faf1d85a769040b16eb SHA1 fde779df7c69b27601da10bca906e94aa961ddc7 SHA256 e000823f92a227bcd6c434b2add953ed9ab2f2c5af48ede070b629444566ba51
+EBUILD idea-ultimate-10.0.1.99.32.ebuild 983 RMD160 631a1e42bc227df0e24a3b7f847fb8fe7e94af3f SHA1 6072fb25c8ad3317ffdd9a4c4b11910d60289802 SHA256 d86ed2b6ed387a264b06907f4ccb7f3987aeea308ce666aa50f918d1f5066041
diff --git a/dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild b/dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild
new file mode 100644
index 0000000..facdf0c
--- /dev/null
+++ b/dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils versionator
+
+SLOT="$(get_major_version)"
+RDEPEND=">=virtual/jdk-1.6"
+
+MY_PV="$(get_version_component_range 4-5)"
+MY_PN="idea"
+
+RESTRICT="strip"
+QA_TEXTRELS="opt/${P}/bin/libbreakgen.so"
+
+DESCRIPTION="IntelliJ IDEA is an intelligent Java IDE"
+HOMEPAGE="http://jetbrains.com/idea/"
+SRC_URI="http://download.jetbrains.com/${MY_PN}/${MY_PN}IU-$(get_version_component_range 1-3).tar.gz"
+LICENSE="IntelliJ-IDEA"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+S="${WORKDIR}/${MY_PN}-IU-${MY_PV}"
+
+RDEPEND="!dev-util/idea-community"
+
+src_install() {
+ local dir="/opt/${P}"
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}/bin/${MY_PN}.sh"
+ local exe=${MY_PN}-${SLOT}
+ local icon=${exe}.png
+ newicon "bin/${MY_PN}32.png" ${icon}
+ dodir /usr/bin
+ make_wrapper "$exe" "/opt/${P}/bin/${MY_PN}.sh"
+ make_desktop_entry ${exe} "IntelliJ IDEA ${PV}" ${icon} "Development;IDE"
+}
diff --git a/layman-local.cfg b/layman-local.cfg
index d026c83..1de41c4 100644
--- a/layman-local.cfg
+++ b/layman-local.cfg
@@ -2,7 +2,7 @@
<layman>
<overlay
type = "git"
- src = "git://github.com/eatnumber1/eatnumber1-overlay.git"
+ src = "git://github.com/eatnumber1/eatnumber1-overlay.git"
status = "unofficial"
contact = "russ@eatnumber1.com"
name = "eatnumber1-overlay">