summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2013-02-25 14:43:42 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:38 +0200
commit3a7062bd2e0be8a422cc373618e9d76d5fd934fc (patch)
tree854edf10d7f090c13d220a26bbdf7dcac3acaaf2 /net-dialup
parentBump zshrc-mv (diff)
downloadmv-3a7062bd2e0be8a422cc373618e9d76d5fd934fc.tar.gz
mv-3a7062bd2e0be8a422cc373618e9d76d5fd934fc.tar.bz2
mv-3a7062bd2e0be8a422cc373618e9d76d5fd934fc.zip
martian-modem: fix compilation with kernel-3.8
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/martian-modem/ChangeLog3
-rw-r--r--net-dialup/martian-modem/files/martian-modem-kernel-3.8.patch22
-rw-r--r--net-dialup/martian-modem/martian-modem-20100123-r1.ebuild (renamed from net-dialup/martian-modem/martian-modem-20100123.ebuild)5
3 files changed, 30 insertions, 0 deletions
diff --git a/net-dialup/martian-modem/ChangeLog b/net-dialup/martian-modem/ChangeLog
index b4dbccd2..8bb33925 100644
--- a/net-dialup/martian-modem/ChangeLog
+++ b/net-dialup/martian-modem/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Feb 2012; Martin Väth <martin@mvath.de>
+ Fix compilation with kernel 3.8. Call epatch_user.
+
19 Dec 2012; Martin Väth <martin@mvath.de>
Add SLOT information
diff --git a/net-dialup/martian-modem/files/martian-modem-kernel-3.8.patch b/net-dialup/martian-modem/files/martian-modem-kernel-3.8.patch
new file mode 100644
index 00000000..eb138df8
--- /dev/null
+++ b/net-dialup/martian-modem/files/martian-modem-kernel-3.8.patch
@@ -0,0 +1,22 @@
+--- kmodule/martian.c
++++ kmodule/martian.c
+@@ -46,6 +46,19 @@
+ #include "../martian.h"
+ #include "marsio.h"
+
++#ifndef __devinit
++#define __devinit
++#endif
++#ifndef __devexit
++#define __devexit
++#endif
++#ifndef __devexit_p
++#define __devexit_p
++#endif
++#ifndef __devinitdata
++#define __devinitdata
++#endif
++
+ /***** Driver globals *****/
+
+ struct proc_dir_entry *martians_proc_dir = NULL;
diff --git a/net-dialup/martian-modem/martian-modem-20100123.ebuild b/net-dialup/martian-modem/martian-modem-20100123-r1.ebuild
index f9d50d79..e9761cd0 100644
--- a/net-dialup/martian-modem/martian-modem-20100123.ebuild
+++ b/net-dialup/martian-modem/martian-modem-20100123-r1.ebuild
@@ -52,6 +52,11 @@ src_prepare() {
BUILD_TARGETS="all"
BUILD_PARAMS="KERNEL_DIR='${KV_DIR}' SUBLEVEL='${KV_PATCH}'"
+
+ if kernel_is ge 3 8
+ then epatch "${FILESDIR}/${PN}-kernel-3.8.patch"
+ fi
+ epatch_user
}
src_install() {