summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-containers/podman-compose/Manifest1
-rw-r--r--app-containers/podman-compose/podman-compose-1.0.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-containers/podman-compose/Manifest b/app-containers/podman-compose/Manifest
new file mode 100644
index 0000000..b79eeef
--- /dev/null
+++ b/app-containers/podman-compose/Manifest
@@ -0,0 +1 @@
+DIST podman-compose-1.0.6.tar.gz 58426 BLAKE2B 4a200d7abb77535d631704e96f600c360cd03a70274c5ed763a6f21a309f9be1225749e4f34b1df00973e9c1de191ec3d43bf35588d912faac25de52e4dd85be SHA512 eb6972c51fd02c7a7dec364d18417c4f093f12ab90ba7061be189de7130c8eb0becb5a1653ebf7db0611470b52257a4a1eaae52891f434ca73fbc6dd30da5f56
diff --git a/app-containers/podman-compose/podman-compose-1.0.6.ebuild b/app-containers/podman-compose/podman-compose-1.0.6.ebuild
new file mode 100644
index 0000000..6b09f29
--- /dev/null
+++ b/app-containers/podman-compose/podman-compose-1.0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1
+
+DESCRIPTION="a script to run docker-compose.yml using podman"
+HOMEPAGE="https://github.com/containers/podman-compose"
+SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm64"
+
+BDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+"
+RDEPEND="${BDEPEND}"
+
+distutils_enable_tests pytest