summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-28 21:03:25 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-28 21:03:25 +0200
commit24bcb5dafaacedd61ea5b032e81500180f98c50e (patch)
tree01344e9891fea7aa81174de328c5277ab9c34c33
parentapp-benchmark/bootchart2-0.14.0: Include changes from bug report (diff)
downloadsystemd-24bcb5dafaacedd61ea5b032e81500180f98c50e.tar.gz
systemd-24bcb5dafaacedd61ea5b032e81500180f98c50e.tar.bz2
systemd-24bcb5dafaacedd61ea5b032e81500180f98c50e.zip
app-benchmark/bootchart2-0.14.0: Properly accept bootchart_init=
-rw-r--r--app-benchmarks/bootchart2/Manifest3
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild8
-rw-r--r--app-benchmarks/bootchart2/files/0001-bootchartd-Look-for-bootchart_init-in-the-environmen.patch28
3 files changed, 38 insertions, 1 deletions
diff --git a/app-benchmarks/bootchart2/Manifest b/app-benchmarks/bootchart2/Manifest
index dd63b78..ccd7b85 100644
--- a/app-benchmarks/bootchart2/Manifest
+++ b/app-benchmarks/bootchart2/Manifest
@@ -1,4 +1,5 @@
+AUX 0001-bootchartd-Look-for-bootchart_init-in-the-environmen.patch 970 RMD160 4b23ae6c9d13e752bd589965f7c45993c7531680 SHA1 e694ff7eeeddb9911daa1748becab1eb01a84b23 SHA256 acc3782a1e9fe87d907937a63b5e92c0b880f1a3c33522c7d8433b37c74e577d
AUX bootchart2 928 RMD160 ddfb9486638f882997492aeb493349f15bfd3e77 SHA1 997e2efd184c134c140142a114190f95fecaa391 SHA256 8a57bb9a2827478467f5b7d183405af5c2b21ed6438551602dcb907e52e19370
DIST bootchart2-0.14.0.tar.bz2 775453 RMD160 5647845f8fd386e5de240c4219d33e3465b39820 SHA1 fb8bede9c4dbc39c8540f1a683fd9ea2f37a104f SHA256 30366efd679568d6d2b12715b01cba6964b55d294da9e1399995d3e15f6e6828
-EBUILD bootchart2-0.14.0.ebuild 2051 RMD160 ae16a266b60ad9becfa987bb87e01dd4724ab394 SHA1 6a60ed2036619f1425f85e074d0fbdd9a47dabcc SHA256 b18d21769bfcdb877daaa0b9df4a3c94a296566aac7400c3a2cec04bc62e4164
+EBUILD bootchart2-0.14.0.ebuild 2437 RMD160 e0d4cad25cd8969b5e0720f30fe961da8a2e7354 SHA1 ecce8b044c9b50fcbf9f4d609cc37c6ad5f45b38 SHA256 60963adf174ca5f300af34585911b3154ed043641135386206a363e582958da1
EBUILD bootchart2-9999.ebuild 2051 RMD160 ae16a266b60ad9becfa987bb87e01dd4724ab394 SHA1 6a60ed2036619f1425f85e074d0fbdd9a47dabcc SHA256 b18d21769bfcdb877daaa0b9df4a3c94a296566aac7400c3a2cec04bc62e4164
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild
index 0563c63..6f930a9 100644
--- a/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild
@@ -43,6 +43,9 @@ src_unpack() {
}
src_prepare() {
+ # properly check for bootchart_init=/path on the kernel command line
+ epatch "${FILESDIR}"/0001-bootchartd-Look-for-bootchart_init-in-the-environmen.patch
+
# correct the version
if [[ "${PV}" = "9999" ]]; then
sed -i Makefile -e "s:VER=$(cat Makefile | grep VER= | cut -d"=" -f2):VER=git-$(date +%Y%m%d):"
@@ -84,4 +87,9 @@ pkg_postinst() {
elog "Note: genkernel users should replace init= with real_init= in the above"
elog "see https://bugs.gentoo.org/show_bug.cgi?id=275251 for more info"
elog
+ elog "If you are not using an initrd, and you are not using /sbin/init as"
+ elog "your init systemd, you should also specify something like this on"
+ elog "your kernel command line"
+ elog " bootchart_init=/path/to/init"
+ elog
}
diff --git a/app-benchmarks/bootchart2/files/0001-bootchartd-Look-for-bootchart_init-in-the-environmen.patch b/app-benchmarks/bootchart2/files/0001-bootchartd-Look-for-bootchart_init-in-the-environmen.patch
new file mode 100644
index 0000000..eade756
--- /dev/null
+++ b/app-benchmarks/bootchart2/files/0001-bootchartd-Look-for-bootchart_init-in-the-environmen.patch
@@ -0,0 +1,28 @@
+From 5ed1882fe71cc3b808a0c5222c0ee9cc716719b8 Mon Sep 17 00:00:00 2001
+From: Henry Gebhardt <hsggebhardt@googlemail.com>
+Date: Sat, 28 May 2011 01:10:57 +0200
+Subject: [PATCH] bootchartd: Look for bootchart_init in the environment
+
+According to bootparam(7) kernel parameters of the form "foo=bar" are
+passed as environment variables, which is also what I observe on Linux
+2.6.39. This patch fixes bootchartd to look for bootchart_init there,
+too.
+---
+ bootchartd.in | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/bootchartd.in b/bootchartd.in
+index ebe9d8b..173b473 100755
+--- a/bootchartd.in
++++ b/bootchartd.in
+@@ -172,6 +172,7 @@ if [ $$ -eq 1 ]; then
+
+ # Optionally, an alternative init(1) process may be specified using
+ # the kernel command line (e.g. "bootchart_init=/sbin/initng")
++ [ -n "$bootchart_init" ] && init="$bootchart_init"
+ for i in $@; do
+ if [ "${i%%=*}" = "bootchart_init" ]; then
+ init="${i#*=}"
+--
+1.7.5.rc3
+