summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-30 03:09:51 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-30 03:12:32 +0200
commit33e4e71145292c9c10e790a22e962eed3d942e4f (patch)
treee26581e6f9974da4dfd10cf1ffa83dee6a9a6b63
parentapp-benchmark/bootchart2-0.14.0: Properly accept bootchart_init= (diff)
downloadsystemd-33e4e71145292c9c10e790a22e962eed3d942e4f.tar.gz
systemd-33e4e71145292c9c10e790a22e962eed3d942e4f.tar.bz2
systemd-33e4e71145292c9c10e790a22e962eed3d942e4f.zip
app-benchmarks/bootchart2: Various fixes
- Let the systemd eclass also decide whether to install units at all. - Remove multilib, because /lib is hardcoded and no libraries are installed. - Remove unneeded phases.
-rw-r--r--app-benchmarks/bootchart2/Manifest4
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild30
-rw-r--r--app-benchmarks/bootchart2/bootchart2-9999.ebuild29
3 files changed, 26 insertions, 37 deletions
diff --git a/app-benchmarks/bootchart2/Manifest b/app-benchmarks/bootchart2/Manifest
index ccd7b85..e7d9ae8 100644
--- a/app-benchmarks/bootchart2/Manifest
+++ b/app-benchmarks/bootchart2/Manifest
@@ -1,5 +1,5 @@
AUX 0001-bootchartd-Look-for-bootchart_init-in-the-environmen.patch 970 RMD160 4b23ae6c9d13e752bd589965f7c45993c7531680 SHA1 e694ff7eeeddb9911daa1748becab1eb01a84b23 SHA256 acc3782a1e9fe87d907937a63b5e92c0b880f1a3c33522c7d8433b37c74e577d
AUX bootchart2 928 RMD160 ddfb9486638f882997492aeb493349f15bfd3e77 SHA1 997e2efd184c134c140142a114190f95fecaa391 SHA256 8a57bb9a2827478467f5b7d183405af5c2b21ed6438551602dcb907e52e19370
DIST bootchart2-0.14.0.tar.bz2 775453 RMD160 5647845f8fd386e5de240c4219d33e3465b39820 SHA1 fb8bede9c4dbc39c8540f1a683fd9ea2f37a104f SHA256 30366efd679568d6d2b12715b01cba6964b55d294da9e1399995d3e15f6e6828
-EBUILD bootchart2-0.14.0.ebuild 2437 RMD160 e0d4cad25cd8969b5e0720f30fe961da8a2e7354 SHA1 ecce8b044c9b50fcbf9f4d609cc37c6ad5f45b38 SHA256 60963adf174ca5f300af34585911b3154ed043641135386206a363e582958da1
-EBUILD bootchart2-9999.ebuild 2051 RMD160 ae16a266b60ad9becfa987bb87e01dd4724ab394 SHA1 6a60ed2036619f1425f85e074d0fbdd9a47dabcc SHA256 b18d21769bfcdb877daaa0b9df4a3c94a296566aac7400c3a2cec04bc62e4164
+EBUILD bootchart2-0.14.0.ebuild 2413 RMD160 a3631a59f7c1f415f26d4e58026542f93aaa3ada SHA1 f9a6da047799be8fafe25d4ea354f1677c096358 SHA256 5eff10a861fa1f885a7ddc8cbc20c391ed6733258040156ae1824c0f2897988c
+EBUILD bootchart2-9999.ebuild 2256 RMD160 29bd016197bc98239052c371d6d1254911e227b1 SHA1 28f080f1011d1e89942e84364f5a8868e80526d7 SHA256 3e4d45f7f92816d7c03e149f8aaa67f7ebe6ae2cf06ac0de5e43aeb4fbf1a3b3
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild
index 6f930a9..d9765bb 100644
--- a/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.0.ebuild
@@ -4,7 +4,7 @@
EAPI="3"
-inherit eutils multilib python linux-info systemd
+inherit eutils linux-info python systemd
DESCRIPTION="Performance analysis and visualization of the system boot process"
HOMEPAGE="https://github.com/mmeeks/bootchart"
@@ -30,10 +30,6 @@ RDEPEND="dev-lang/python
dev-python/pycairo[svg=]"
DEPEND="${RDEPEND}"
-pkg_setup() {
- linux-info_pkg_setup
-}
-
src_unpack() {
if [[ "${PV}" = "9999" ]]; then
git_src_unpack
@@ -50,29 +46,25 @@ src_prepare() {
if [[ "${PV}" = "9999" ]]; then
sed -i Makefile -e "s:VER=$(cat Makefile | grep VER= | cut -d"=" -f2):VER=git-$(date +%Y%m%d):"
fi
-
- # make systemd unit dir configurable
- sed -i Makefile -e 's:^SYSTEMD_UNIT_DIR = :SYSTEMD_UNIT_DIR ?= :'
-}
-
-src_compile() {
- emake \
- LIBDIR="$(get_libdir)" || die "died running make, $FUNCNAME"
}
src_install() {
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
emake \
DESTDIR="${D}" \
- LIBDIR="$(get_libdir)" \
PY_LIBDIR="$(python_get_libdir)" \
- SYSTEMD_UNIT_DIR="$(systemd_get_unitdir)" \
DOCDIR="/usr/share/doc/${PN}-${PVR}" \
install || die "died running make install, $FUNCNAME"
- keepdir /$(get_libdir)/bootchart/tmpfs
+ keepdir /lib/bootchart/tmpfs
doinitd "${FILESDIR}/${PN}"
+ # Install systemd units where and whether the eclass wants them:
+ mv "${D}"/lib/systemd/system systemd-units || die
+ systemd_dounit systemd-units/* || die
+
prepalldocs
dodoc README README.pybootchart AUTHORS MAINTAINERS NEWS TODO || die
@@ -88,8 +80,8 @@ pkg_postinst() {
elog "see https://bugs.gentoo.org/show_bug.cgi?id=275251 for more info"
elog
elog "If you are not using an initrd, and you are not using /sbin/init as"
- elog "your init systemd, you should also specify something like this on"
- elog "your kernel command line"
- elog " bootchart_init=/path/to/init"
+ elog "your init system, you must additionally specify something like this"
+ elog "on your kernel command line"
+ elog " bootchart_init=/bin/systemd"
elog
}
diff --git a/app-benchmarks/bootchart2/bootchart2-9999.ebuild b/app-benchmarks/bootchart2/bootchart2-9999.ebuild
index 0563c63..767a093 100644
--- a/app-benchmarks/bootchart2/bootchart2-9999.ebuild
+++ b/app-benchmarks/bootchart2/bootchart2-9999.ebuild
@@ -4,7 +4,7 @@
EAPI="3"
-inherit eutils multilib python linux-info systemd
+inherit eutils linux-info python systemd
DESCRIPTION="Performance analysis and visualization of the system boot process"
HOMEPAGE="https://github.com/mmeeks/bootchart"
@@ -30,10 +30,6 @@ RDEPEND="dev-lang/python
dev-python/pycairo[svg=]"
DEPEND="${RDEPEND}"
-pkg_setup() {
- linux-info_pkg_setup
-}
-
src_unpack() {
if [[ "${PV}" = "9999" ]]; then
git_src_unpack
@@ -47,29 +43,25 @@ src_prepare() {
if [[ "${PV}" = "9999" ]]; then
sed -i Makefile -e "s:VER=$(cat Makefile | grep VER= | cut -d"=" -f2):VER=git-$(date +%Y%m%d):"
fi
-
- # make systemd unit dir configurable
- sed -i Makefile -e 's:^SYSTEMD_UNIT_DIR = :SYSTEMD_UNIT_DIR ?= :'
-}
-
-src_compile() {
- emake \
- LIBDIR="$(get_libdir)" || die "died running make, $FUNCNAME"
}
src_install() {
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
emake \
DESTDIR="${D}" \
- LIBDIR="$(get_libdir)" \
PY_LIBDIR="$(python_get_libdir)" \
- SYSTEMD_UNIT_DIR="$(systemd_get_unitdir)" \
DOCDIR="/usr/share/doc/${PN}-${PVR}" \
install || die "died running make install, $FUNCNAME"
- keepdir /$(get_libdir)/bootchart/tmpfs
+ keepdir /lib/bootchart/tmpfs
doinitd "${FILESDIR}/${PN}"
+ # Install systemd units where and whether the eclass wants them:
+ mv "${D}"/lib/systemd/system systemd-units || die
+ systemd_dounit systemd-units/* || die
+
prepalldocs
dodoc README README.pybootchart AUTHORS MAINTAINERS NEWS TODO || die
@@ -84,4 +76,9 @@ pkg_postinst() {
elog "Note: genkernel users should replace init= with real_init= in the above"
elog "see https://bugs.gentoo.org/show_bug.cgi?id=275251 for more info"
elog
+ elog "If you are not using an initrd, and you are not using /sbin/init as"
+ elog "your init system, you must additionally specify something like this"
+ elog "on your kernel command line"
+ elog " bootchart_init=/bin/systemd"
+ elog
}