summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-06-21 15:27:41 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-06-21 15:34:54 +0200
commit6ab8f553d836d215f67e584e957a3461c26ec9e0 (patch)
tree272dd39035e99cc4ed12be6a8af9db938a6f0f3d
parentsys-apps/systemd-28: synchronize with in-tree ebuild (diff)
downloadsystemd-6ab8f553d836d215f67e584e957a3461c26ec9e0.tar.gz
systemd-6ab8f553d836d215f67e584e957a3461c26ec9e0.tar.bz2
systemd-6ab8f553d836d215f67e584e957a3461c26ec9e0.zip
sys-apps/systemd-28: Convert to autotools
Three differences to the in-tree ebuild remain: - udev dependency, because many packages still depend on udev[extra]. This means that udev-171 which includes systemd files is not installed. - We still depend on systemd-units, just for the moment. - We install the .pc file. Just so we can easily find which packages install systemd files automatically.
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-28.ebuild15
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index 2f95b9c..77c14ae 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -1,6 +1,6 @@
DIST systemd-26.tar.bz2 791117 RMD160 06836ca8daf0c5ebc113940357289348561dac56 SHA1 901486904aeb1d8a3ae20e5971afd9b42b847450 SHA256 d7a222c09cdb0a9eebe97c7c499c458cc29ef8b3b2d0ca79bb949b2fd3d077d3
DIST systemd-28.tar.bz2 810357 RMD160 0d91101b158af98cbd7d9be35f5a9dae51d565fc SHA1 8c8e04f4577afcc7fa5f28205d581594fe69367b SHA256 dd11cc85b2f2afc8094cefb47af519d5a03a9ec1abce0fb82bc19d48fa471b33
EBUILD systemd-26.ebuild 4327 RMD160 d26de8d5b632a0c96b2dc19441d0d0d57bbfa2da SHA1 188fa736286c9bbc48147b732512243ed0e9a60d SHA256 0499bf01d2e23cf5106139597d0d2eec54625463da808285f9562dc7a6c735e1
-EBUILD systemd-28.ebuild 3215 RMD160 0c2ecf8524a00dd3630f6a44a86d9b0a4a2d0509 SHA1 1bbb6528cdd8cb424fc9393ee6a6cfbf90ff4128 SHA256 93b69969d8fe732f83e93b1364347360aafbe500aa9785e464559f706e882fe7
+EBUILD systemd-28.ebuild 3346 RMD160 73d7a20821cecf752cc5c4281846175fe4bec6cc SHA1 c1a8b0084aa2686ef607c8152445fd1bad5866bf SHA256 c98c077cf207cefd6f3d1c7b999244c58b979927fd59ee7bfcc65ab28ee0fe43
EBUILD systemd-9999.ebuild 4405 RMD160 2c5a3056bcb324e699cf91335e269accfd09e084 SHA1 93faa0d5fc75516ee410df92de2dc4ee8c994384 SHA256 fa1281797ded87f02d624580ed83d7ff4054929b37331950dd963fa3d699d85c
MISC metadata.xml 737 RMD160 cdd440f38c039bfa7967fd713ef238588c2e1fb4 SHA1 1dea5e1d1e388bf43131297667bb4dbba10e65dd SHA256 042b1b68c02c274920954280705e21c2ca2ef5eece3229aab03d8dd43e06422d
diff --git a/sys-apps/systemd/systemd-28.ebuild b/sys-apps/systemd/systemd-28.ebuild
index c6b094a..2559f65 100644
--- a/sys-apps/systemd/systemd-28.ebuild
+++ b/sys-apps/systemd/systemd-28.ebuild
@@ -4,7 +4,7 @@
EAPI=4
-inherit eutils linux-info pam
+inherit autotools-utils linux-info pam
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="audit cryptsetup gtk pam plymouth selinux tcpd"
COMMON_DEPEND=">=sys-apps/dbus-1.4.10
- >=sys-fs/udev-163[systemd]
+ || ( >=sys-fs/udev-171 >=sys-fs/udev-163[systemd] )
>=sys-apps/util-linux-2.19
sys-libs/libcap
audit? ( >=sys-process/audit-2 )
@@ -39,6 +39,8 @@ MINKV="2.6.38"
RDEPEND="${COMMON_DEPEND}
sys-apps/systemd-units
+ !!sys-apps/systemd-dbus
+ !!sys-apps/systemd-udev
!<sys-apps/openrc-0.8.3"
DEPEND="${COMMON_DEPEND}
gtk? ( dev-lang/vala:${VALASLOT} )
@@ -58,10 +60,11 @@ pkg_setup() {
src_prepare() {
# Force the rebuild of .vala sources
touch src/*.vala || die
+ autotools-utils_src_prepare
}
src_configure() {
- local myconf="
+ local myeconfargs=(
--with-distro=gentoo
--with-rootdir=
--localstatedir=/var
@@ -75,17 +78,17 @@ src_configure() {
# right now it is enabled on per-distro basis
# let's just hack into the check
$(use plymouth && echo have_plymouth=true)
- "
+ )
if use gtk; then
export VALAC="$(type -p valac-${VALASLOT})"
fi
- econf ${myconf}
+ autotools-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install
+ autotools-utils_src_install
dodoc "${D}"/usr/share/doc/systemd/*
rm -rf "${D}"/usr/share/doc/systemd || die