summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGLSAMaker <glsamaker@gentoo.org>2022-10-31 20:24:49 +0000
committerJohn Helmert III <ajak@gentoo.org>2022-10-31 15:25:51 -0500
commitb966ebfc6ef872316dabbe9fe102bd7f47faadb1 (patch)
tree57256ab19fbc918083077045b530f5c40c845f5f
parent[ GLSA 202210-39 ] libxml2: Multiple Vulnerabilities (diff)
downloadglsa-b966ebfc6ef872316dabbe9fe102bd7f47faadb1.tar.gz
glsa-b966ebfc6ef872316dabbe9fe102bd7f47faadb1.tar.bz2
glsa-b966ebfc6ef872316dabbe9fe102bd7f47faadb1.zip
[ GLSA 202210-40 ] SQLite: Multiple Vulnerabilities
Bug: https://bugs.gentoo.org/777990 Bug: https://bugs.gentoo.org/863431 Signed-off-by: GLSAMaker <glsamaker@gentoo.org> Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--glsa-202210-40.xml44
1 files changed, 44 insertions, 0 deletions
diff --git a/glsa-202210-40.xml b/glsa-202210-40.xml
new file mode 100644
index 00000000..6f4199b2
--- /dev/null
+++ b/glsa-202210-40.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
+<glsa id="202210-40">
+ <title>SQLite: Multiple Vulnerabilities</title>
+ <synopsis>Multiple vulnerabilities have been found in SQLite, the worst of which could result in arbitrary code execution.</synopsis>
+ <product type="ebuild">sqlite</product>
+ <announced>2022-10-31</announced>
+ <revised count="1">2022-10-31</revised>
+ <bug>777990</bug>
+ <bug>863431</bug>
+ <access>remote</access>
+ <affected>
+ <package name="dev-db/sqlite" auto="yes" arch="*">
+ <unaffected range="ge">3.39.2</unaffected>
+ <vulnerable range="lt">3.39.2</vulnerable>
+ </package>
+ </affected>
+ <background>
+ <p>SQLite is a C library that implements an SQL database engine.</p>
+ </background>
+ <description>
+ <p>Multiple vulnerabilities have been discovered in SQLite. Please review the CVE identifiers referenced below for details.</p>
+ </description>
+ <impact type="high">
+ <p>Please review the referenced CVE identifiers for details.</p>
+ </impact>
+ <workaround>
+ <p>There is no known workaround at this time.</p>
+ </workaround>
+ <resolution>
+ <p>All SQLite users should upgrade to the latest version:</p>
+
+ <code>
+ # emerge --sync
+ # emerge --ask --oneshot --verbose ">=dev-db/sqlite-3.39.2"
+ </code>
+ </resolution>
+ <references>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-20227">CVE-2021-20227</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2022-35737">CVE-2022-35737</uri>
+ </references>
+ <metadata tag="requester" timestamp="2022-10-31T20:24:49.875919Z">ajak</metadata>
+ <metadata tag="submitter" timestamp="2022-10-31T20:24:49.881750Z">ajak</metadata>
+</glsa> \ No newline at end of file