summaryrefslogtreecommitdiff
blob: f9168c3f181197b5a458d7e8fbef1f4845a08cf7 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200408-02">
  <title>Courier: Cross-site scripting vulnerability in SqWebMail</title>
  <synopsis>
    The SqWebMail web application, included in the Courier suite, is vulnerable
    to cross-site scripting attacks.
  </synopsis>
  <product type="ebuild">Courier</product>
  <announced>2004-08-04</announced>
  <revised>2004-08-04: 01</revised>
  <bug>58020</bug>
  <access>remote</access>
  <affected>
    <package name="mail-mta/courier" auto="yes" arch="*">
      <unaffected range="ge">0.45.6.20040618</unaffected>
      <vulnerable range="le">0.45.6</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Courier is an integrated mail and groupware server based on open protocols.
    It provides ESMTP, IMAP, POP3, webmail, and mailing list services within a
    single framework. The webmail functionality included in Courier called
    SqWebMail allows you to access mailboxes from a web browser.
    </p>
  </background>
  <description>
    <p>
    Luca Legato found that SqWebMail is vulnerable to a cross-site scripting
    (XSS) attack. An XSS attack allows an attacker to insert malicious code
    into a web-based application. SqWebMail doesn't filter appropriately data
    coming from message headers before displaying them.
    </p>
  </description>
  <impact type="normal">
    <p>
    By sending a carefully crafted message, an attacker can inject and execute
    script code in the victim's browser window. This allows to modify the
    behaviour of the SqWebMail application, and/or leak session information
    such as cookies to the attacker.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time. All users are encouraged to
    upgrade to the latest available version of Courier.
    </p>
  </workaround>
  <resolution>
    <p>
    All Courier users should upgrade to the latest version:
    </p>
    <code>
    # emerge sync

    # emerge -pv "&gt;=mail-mta/courier-0.45.6.20040618"
    # emerge "&gt;=mail-mta/courier-0.45.6.20040618"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0591">CAN-2004-0591</uri>
    <uri link="https://www.cert.org/advisories/CA-2000-02.html">XSS definition</uri>
  </references>
  <metadata tag="requester">
    koon
  </metadata>
  <metadata tag="submitter" timestamp="2004-08-03T15:23:08Z">
    koon
  </metadata>
</glsa>