summaryrefslogtreecommitdiff
blob: ad33013da8ff0552dc4ed1a8e1d5ade9d6fc7c80 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200408-06">
  <title>SpamAssassin: Denial of Service vulnerability</title>
  <synopsis>
    SpamAssassin is vulnerable to a Denial of Service attack when handling
    certain malformed messages.
  </synopsis>
  <product type="ebuild">SpamAssassin</product>
  <announced>2004-08-09</announced>
  <revised>2006-05-22: 02</revised>
  <bug>59483</bug>
  <access>remote</access>
  <affected>
    <package name="mail-filter/spamassassin" auto="yes" arch="*">
      <unaffected range="ge">2.64</unaffected>
      <vulnerable range="le">2.63-r1</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    SpamAssassin is an extensible email filter which is used to identify
    spam.
    </p>
  </background>
  <description>
    <p>
    SpamAssassin contains an unspecified Denial of Service vulnerability.
    </p>
  </description>
  <impact type="normal">
    <p>
    By sending a specially crafted message an attacker could cause a Denial
    of Service attack against the SpamAssassin service.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time. All users are encouraged to
    upgrade to the latest available version of SpamAssassin.
    </p>
  </workaround>
  <resolution>
    <p>
    All SpamAssassin users should upgrade to the latest version:
    </p>
    <code>
    # emerge sync
    
    # emerge -pv "&gt;=mail-filter/spamassassin-2.64"
    # emerge "&gt;=mail-filter/spamassassin-2.64"</code>
  </resolution>
  <references>
    <uri link="http://marc.theaimsgroup.com/?l=spamassassin-announce&amp;m=109168121628767&amp;w=2">SpamAssassin Release Announcement</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0796">CVE-2004-0796</uri>
  </references>
  <metadata tag="requester" timestamp="2004-08-05T09:14:09Z">
    koon
  </metadata>
  <metadata tag="submitter" timestamp="2004-08-05T11:01:34Z">
    jaervosz
  </metadata>
</glsa>