summaryrefslogtreecommitdiff
blob: 51161d8b05d5e09e631e7d38e8d37bc70e9b1c11 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200409-29">
  <title>FreeRADIUS: Multiple Denial of Service vulnerabilities</title>
  <synopsis>
    Multiple Denial of Service vulnerabilities were found and fixed in
    FreeRADIUS.
  </synopsis>
  <product type="ebuild">FreeRADIUS</product>
  <announced>2004-09-22</announced>
  <revised>2006-05-22: 02</revised>
  <bug>60587</bug>
  <access>remote</access>
  <affected>
    <package name="net-dialup/freeradius" auto="yes" arch="*">
      <unaffected range="ge">1.0.1</unaffected>
      <vulnerable range="lt">1.0.1</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    FreeRADIUS is an open source RADIUS authentication server
    implementation.
    </p>
  </background>
  <description>
    <p>
    There are undisclosed defects in the way FreeRADIUS handles incorrect
    received packets.
    </p>
  </description>
  <impact type="normal">
    <p>
    A remote attacker could send specially-crafted packets to the
    FreeRADIUS server to deny service to other users by crashing the
    server.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All FreeRADIUS users should upgrade to the latest version:
    </p>
    <code>
    # emerge sync
    
    # emerge -pv "&gt;=net-dialup/freeradius-1.0.1"
    # emerge "&gt;=net-dialup/freeradius-1.0.1"</code>
  </resolution>
  <references>
    <uri link="https://www.freeradius.org/security.html">FreeRADIUS Vulnerability Notifications</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0938">CVE-2004-0938</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0960">CVE-2004-0960</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0961">CVE-2004-0961</uri>
  </references>
  <metadata tag="requester" timestamp="2004-09-20T13:27:45Z">
    jaervosz
  </metadata>
  <metadata tag="submitter" timestamp="2004-09-20T15:22:58Z">
    koon
  </metadata>
  <metadata tag="bugReady" timestamp="2004-09-21T11:24:01Z">
    koon
  </metadata>
</glsa>