summaryrefslogtreecommitdiff
blob: 85af50681cbf3a47ac498331dbdeb28cd98055bf (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200502-06">
  <title>LessTif: Multiple vulnerabilities in libXpm</title>
  <synopsis>
    Multiple vulnerabilities have been discovered in libXpm, which is included
    in LessTif, that can potentially lead to remote code execution.
  </synopsis>
  <product type="ebuild">lesstif</product>
  <announced>2005-02-06</announced>
  <revised>2005-02-06: 01</revised>
  <bug>78483</bug>
  <access>remote</access>
  <affected>
    <package name="x11-libs/lesstif" auto="yes" arch="*">
      <unaffected range="ge">0.94.0</unaffected>
      <vulnerable range="lt">0.94.0</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    LessTif is a clone of OSF/Motif, which is a standard user
    interface toolkit available on Unix and Linux.
    </p>
  </background>
  <description>
    <p>
    Multiple vulnerabilities, including buffer overflows, out of
    bounds memory access and directory traversals, have been discovered in
    libXpm, which is shipped as a part of the X Window System. LessTif, an
    application that includes libXpm, suffers from the same issues.
    </p>
  </description>
  <impact type="normal">
    <p>
    A carefully-crafted XPM file could crash applications making use
    of the LessTif toolkit, potentially allowing the execution of arbitrary
    code with the privileges of the user running the application.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All LessTif users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=x11-libs/lesstif-0.94.0"</code>
  </resolution>
  <references>
    <uri link="https://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0914">CAN-2004-0914</uri>
    <uri link="http://www.lesstif.org/ReleaseNotes.html">LessTif Release Notes</uri>
  </references>
  <metadata tag="submitter" timestamp="2005-02-02T16:13:30Z">
    DerCorny
  </metadata>
  <metadata tag="bugReady" timestamp="2005-02-06T17:18:21Z">
    koon
  </metadata>
</glsa>