summaryrefslogtreecommitdiff
blob: 571b3df853ec3ae46719a92169f779c112726b28 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200506-06">
  <title>libextractor: Multiple overflow vulnerabilities</title>
  <synopsis>
    libextractor is affected by several overflow vulnerabilities in the PDF,
    Real and PNG extractors, making it vulnerable to execution of arbitrary
    code.
  </synopsis>
  <product type="ebuild">libextractor</product>
  <announced>2005-06-09</announced>
  <revised>2005-06-09: 01</revised>
  <bug>79704</bug>
  <access>remote</access>
  <affected>
    <package name="media-libs/libextractor" auto="yes" arch="*">
      <unaffected range="ge">0.5.0</unaffected>
      <vulnerable range="lt">0.5.0</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    libextractor is a library used to extract meta-data from files. It
    makes use of Xpdf code to extract information from PDF files.
    </p>
  </background>
  <description>
    <p>
    Xpdf is vulnerable to multiple overflows, as described in GLSA
    200501-28. Also, integer overflows were discovered in Real and PNG
    extractors.
    </p>
  </description>
  <impact type="normal">
    <p>
    An attacker could design malicious PDF, PNG or Real files which,
    when processed by an application making use of libextractor, would
    result in the execution of arbitrary code with the rights of the user
    running the application.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All libextractor users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=media-libs/libextractor-0.5.0"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0064">CAN-2005-0064</uri>
    <uri link="https://www.gentoo.org/security/en/glsa/glsa-200501-28.xml">GLSA 200501-28</uri>
    <uri link="https://gnunet.org/libextractor/">libextractor security announcement</uri>
  </references>
  <metadata tag="requester" timestamp="2005-03-01T11:13:31Z">
    koon
  </metadata>
  <metadata tag="submitter" timestamp="2005-03-03T15:44:04Z">
    formula7
  </metadata>
  <metadata tag="bugReady" timestamp="2005-06-08T11:34:48Z">
    koon
  </metadata>
</glsa>