summaryrefslogtreecommitdiff
blob: d66e6520e4ae49ca75ce331f0b99842d6f6d9dca (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200507-28">
  <title>AMD64 x86 emulation base libraries: Buffer overflow</title>
  <synopsis>
    The x86 emulation base libraries for AMD64 contain a vulnerable version of
    zlib which could potentially lead to execution of arbitrary code.
  </synopsis>
  <product type="ebuild">emul-linux-x86-baselibs</product>
  <announced>2005-07-30</announced>
  <revised>2005-08-02: 02</revised>
  <bug>100686</bug>
  <access>remote</access>
  <affected>
    <package name="app-emulation/emul-linux-x86-baselibs" auto="yes" arch="AMD64">
      <unaffected range="ge">2.1.2</unaffected>
      <vulnerable range="lt">2.1.2</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    The x86 emulation base libraries for AMD64 emulate the x86 (32-bit)
    architecture on the AMD64 (64-bit) architecture.
    </p>
  </background>
  <description>
    <p>
    Earlier versions of emul-linux-x86-baselibs contain a vulnerable
    version of zlib, which may lead to a buffer overflow.
    </p>
  </description>
  <impact type="high">
    <p>
    By creating a specially crafted compressed data stream, attackers can
    overwrite data structures for applications that use the x86 emulation
    base libraries for AMD64, resulting in a Denial of Service and
    potentially arbitrary code execution.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All AMD64 x86 emulation base libraries users should upgrade to the
    latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose app-emulation/emul-linux-x86-baselibs</code>
  </resolution>
  <references>
    <uri link="https://www.gentoo.org/security/en/glsa/glsa-200507-05.xml">GLSA 200507-05</uri>
    <uri link="https://www.gentoo.org/security/en/glsa/glsa-200507-19.xml">GLSA 200507-19</uri>
    <uri link="https://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1849">CAN-2005-1849</uri>
    <uri link="https://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2096">CAN-2005-2096</uri>
  </references>
  <metadata tag="requester" timestamp="2005-07-30T08:48:26Z">
    koon
  </metadata>
  <metadata tag="bugReady" timestamp="2005-07-30T08:50:21Z">
    koon
  </metadata>
  <metadata tag="submitter" timestamp="2005-07-30T09:53:12Z">
    adir
  </metadata>
</glsa>