summaryrefslogtreecommitdiff
blob: 2e1fc0e3cfb0573665c37448be3c64e62b8cabcd (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200509-12">
  <title>Apache, mod_ssl: Multiple vulnerabilities</title>
  <synopsis>
    mod_ssl and Apache are vulnerable to a restriction bypass and a potential
    local privilege escalation.
  </synopsis>
  <product type="ebuild">Apache</product>
  <announced>2005-09-19</announced>
  <revised>2007-12-30: 03</revised>
  <bug>103554</bug>
  <bug>104807</bug>
  <access>remote and local</access>
  <affected>
    <package name="net-www/mod_ssl" auto="yes" arch="*">
      <unaffected range="ge">2.8.24</unaffected>
      <vulnerable range="lt">2.8.24</vulnerable>
    </package>
    <package name="www-servers/apache" auto="yes" arch="*">
      <unaffected range="ge">2.0.54-r15</unaffected>
      <unaffected range="lt">2</unaffected>
      <vulnerable range="lt">2.0.54-r15</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    The Apache HTTP server is one of the most popular web servers on the
    Internet. mod_ssl provides SSL v2/v3 and TLS v1 support for Apache 1.3
    and is also included in Apache 2.
    </p>
  </background>
  <description>
    <p>
    mod_ssl contains a security issue when "SSLVerifyClient optional" is
    configured in the global virtual host configuration (CAN-2005-2700).
    Also, Apache's httpd includes a PCRE library, which makes it vulnerable
    to an integer overflow (CAN-2005-2491).
    </p>
  </description>
  <impact type="normal">
    <p>
    Under a specific configuration, mod_ssl does not properly enforce the
    client-based certificate authentication directive, "SSLVerifyClient
    require", in a per-location context, which could be potentially used by
    a remote attacker to bypass some restrictions. By creating a specially
    crafted ".htaccess" file, a local attacker could possibly exploit
    Apache's vulnerability, which would result in a local privilege
    escalation.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All mod_ssl users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=net-www/mod_ssl-2.8.24"</code>
    <p>
    All Apache 2 users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=www-servers/apache-2.0.54-r15"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2491">CAN-2005-2491</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2700">CAN-2005-2700</uri>
  </references>
  <metadata tag="requester" timestamp="2005-09-11T10:15:26Z">
    koon
  </metadata>
  <metadata tag="bugReady" timestamp="2005-09-16T16:41:43Z">
    koon
  </metadata>
  <metadata tag="submitter" timestamp="2005-09-17T14:36:28Z">
    formula7
  </metadata>
</glsa>