summaryrefslogtreecommitdiff
blob: d8724e94e2c34ee38272ebfd7e3f9f8c5a730a65 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200510-25">
  <title>Ethereal: Multiple vulnerabilities in protocol dissectors</title>
  <synopsis>
    Ethereal is vulnerable to numerous vulnerabilities, potentially resulting
    in the execution of arbitrary code or abnormal termination.
  </synopsis>
  <product type="ebuild">Ethereal</product>
  <announced>2005-10-30</announced>
  <revised>2005-10-30: 01</revised>
  <bug>109348</bug>
  <access>remote</access>
  <affected>
    <package name="net-analyzer/ethereal" auto="yes" arch="*">
      <unaffected range="ge">0.10.13-r1</unaffected>
      <vulnerable range="lt">0.10.13-r1</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Ethereal is a feature-rich network protocol analyzer.
    </p>
  </background>
  <description>
    <p>
    There are numerous vulnerabilities in versions of Ethereal prior
    to 0.10.13, including:
    </p>
    <ul>
    <li>The SLIM3 and AgentX dissectors
    could overflow a buffer (CVE-2005-3243).</li>
    <li>iDEFENSE discovered a
    buffer overflow in the SRVLOC dissector (CVE-2005-3184).</li>
    <li>Multiple potential crashes in many dissectors have been fixed, see
    References for further details.</li>
    </ul>
    <p>
    Furthermore an infinite
    loop was discovered in the IRC protocol dissector of the 0.10.13
    release (CVE-2005-3313).
    </p>
  </description>
  <impact type="high">
    <p>
    An attacker might be able to use these vulnerabilities to crash
    Ethereal or execute arbitrary code with the permissions of the user
    running Ethereal, which could be the root user.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All Ethereal users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=net-analyzer/ethereal-0.10.13-r1"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3184">CVE-2005-3184</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3241">CVE-2005-3241</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3242">CVE-2005-3242</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3243">CVE-2005-3243</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3244">CVE-2005-3244</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3245">CVE-2005-3245</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3246">CVE-2005-3246</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3247">CVE-2005-3247</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3248">CVE-2005-3248</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3249">CVE-2005-3249</uri>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3313">CVE-2005-3313</uri>
    <uri link="http://www.ethereal.com/appnotes/enpa-sa-00021.html">Ethereal enpa-sa-00021</uri>
  </references>
  <metadata tag="submitter" timestamp="2005-10-17T05:29:11Z">
    jaervosz
  </metadata>
  <metadata tag="bugReady" timestamp="2005-10-30T09:10:32Z">
    adir
  </metadata>
</glsa>