summaryrefslogtreecommitdiff
blob: 9c033f7866ba79b538d85498fcde4c735ff369c2 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200512-05">
  <title>Xmail: Privilege escalation through sendmail</title>
  <synopsis>
    The sendmail program in Xmail is vulnerable to a buffer overflow,
    potentially resulting in local privilege escalation.
  </synopsis>
  <product type="ebuild">xmail</product>
  <announced>2005-12-14</announced>
  <revised>2005-12-14: 01</revised>
  <bug>109381</bug>
  <access>local</access>
  <affected>
    <package name="mail-mta/xmail" auto="yes" arch="*">
      <unaffected range="ge">1.22</unaffected>
      <vulnerable range="lt">1.22</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Xmail is an Internet and intranet mail server.
    </p>
  </background>
  <description>
    <p>
    iDEFENSE reported that the AddressFromAtPtr function in the
    sendmail program fails to check bounds on arguments passed from other
    functions, and as a result an exploitable stack overflow condition
    occurs when specifying the "-t" command line option.
    </p>
  </description>
  <impact type="high">
    <p>
    A local attacker can make a malicious call to sendmail,
    potentially resulting in code execution with elevated privileges.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All Xmail users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=mail-mta/xmail-1.22"</code>
  </resolution>
  <references>
    <uri link="https://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2943">CVE-2005-2943</uri>
    <uri link="http://www.idefense.com/application/poi/display?id=321&amp;type=vulnerabilities&amp;flashstatus=true">iDEFENSE Security Advisory</uri>
  </references>
  <metadata tag="requester" timestamp="2005-12-11T18:01:24Z">
    koon
  </metadata>
  <metadata tag="bugReady" timestamp="2005-12-12T15:24:20Z">
    koon
  </metadata>
  <metadata tag="submitter" timestamp="2005-12-13T08:46:36Z">
    adir
  </metadata>
</glsa>