summaryrefslogtreecommitdiff
blob: db1a2920e223d8fba4998a10c199705c156ba2e9 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200602-06">
  <title>ImageMagick: Format string vulnerability</title>
  <synopsis>
    A vulnerability in ImageMagick allows attackers to crash the application
    and potentially execute arbitrary code.
  </synopsis>
  <product type="ebuild">ImageMagick</product>
  <announced>2006-02-13</announced>
  <revised>2006-02-13: 01</revised>
  <bug>83542</bug>
  <access>remote</access>
  <affected>
    <package name="media-gfx/imagemagick" auto="yes" arch="*">
      <unaffected range="ge">6.2.5.5</unaffected>
      <vulnerable range="lt">6.2.5.5</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    ImageMagick is an application suite to manipulate and convert
    images. It is often used as a utility backend by web applications like
    forums, content management systems or picture galleries.
    </p>
  </background>
  <description>
    <p>
    The SetImageInfo function was found vulnerable to a format string
    mishandling. Daniel Kobras discovered that the handling of "%"-escaped
    sequences in filenames passed to the function is inadequate. This is a
    new vulnerability that is not addressed by GLSA 200503-11.
    </p>
  </description>
  <impact type="normal">
    <p>
    By feeding specially crafted file names to ImageMagick, an
    attacker can crash the program and possibly execute arbitrary code with
    the privileges of the user running ImageMagick.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All ImageMagick users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=media-gfx/imagemagick-6.2.5.5"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0082">CVE-2006-0082</uri>
    <uri link="https://www.gentoo.org/security/en/glsa/glsa-200503-11.xml">GLSA 200503-11</uri>
  </references>
  <metadata tag="requester" timestamp="2006-02-01T19:11:00Z">
    jaervosz
  </metadata>
  <metadata tag="submitter" timestamp="2006-02-02T08:22:50Z">
    frilled
  </metadata>
  <metadata tag="bugReady" timestamp="2006-02-09T18:59:37Z">
    koon
  </metadata>
</glsa>