summaryrefslogtreecommitdiff
blob: 42d28bd54cd68b630ad24c6b78f03a0429a09301 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200603-01">
  <title>WordPress: SQL injection vulnerability</title>
  <synopsis>
    WordPress is vulnerable to an SQL injection vulnerability.
  </synopsis>
  <product type="ebuild">WordPress</product>
  <announced>2006-03-04</announced>
  <revised>2006-03-04: 01</revised>
  <bug>121661</bug>
  <access>remote</access>
  <affected>
    <package name="www-apps/wordpress" auto="yes" arch="*">
      <unaffected range="ge">2.0.1</unaffected>
      <vulnerable range="le">1.5.2</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    WordPress is a PHP and MySQL based content management and
    publishing system.
    </p>
  </background>
  <description>
    <p>
    Patrik Karlsson reported that WordPress 1.5.2 makes use of an
    insufficiently filtered User Agent string in SQL queries related to
    comments posting. This vulnerability was already fixed in the
    2.0-series of WordPress.
    </p>
  </description>
  <impact type="normal">
    <p>
    An attacker could send a comment with a malicious User Agent
    parameter, resulting in SQL injection and potentially in the subversion
    of the WordPress database. This vulnerability wouldn't affect WordPress
    sites which do not allow comments or which require that comments go
    through a moderator.
    </p>
  </impact>
  <workaround>
    <p>
    Disable or moderate comments on your WordPress blogs.
    </p>
  </workaround>
  <resolution>
    <p>
    All WordPress users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=www-apps/wordpress-2.0.1"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1012">CVE-2006-1012</uri>
  </references>
  
  <metadata tag="submitter" timestamp="2006-02-26T14:42:26Z">
    koon
  </metadata>
  <metadata tag="bugReady" timestamp="2006-02-26T14:42:47Z">
    koon
  </metadata>
</glsa>