summaryrefslogtreecommitdiff
blob: 64ef7c6c2307de1eea84b8971705ea9f07571ed5 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200703-26">
  <title>file: Integer underflow</title>
  <synopsis>
    A buffer underflow vulnerability has been reported in file allowing for the
    user-assisted execution of arbitrary code.
  </synopsis>
  <product type="ebuild">file</product>
  <announced>2007-03-30</announced>
  <revised>2007-03-30: 01</revised>
  <bug>171452</bug>
  <access>remote</access>
  <affected>
    <package name="sys-apps/file" auto="yes" arch="*">
      <unaffected range="ge">4.20</unaffected>
      <vulnerable range="lt">4.20</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    file is a utility that guesses a file format by scanning binary data
    for patterns.
    </p>
  </background>
  <description>
    <p>
    Jean-Sebastien Guay-Leroux reported an integer underflow in
    file_printf function.
    </p>
  </description>
  <impact type="high">
    <p>
    A remote attacker could entice a user to run the "file" program on a
    specially crafted file that would trigger a heap-based buffer overflow
    possibly leading to the execution of arbitrary code with the rights of
    the user running "file". Note that this vulnerability could be also
    triggered through an automatic file scanner like amavisd-new.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    Since file is a system package, all Gentoo users should upgrade to the
    latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=sys-apps/file-4.20"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1536">CVE-2007-1536</uri>
  </references>
  <metadata tag="requester" timestamp="2007-03-24T17:59:07Z">
    jaervosz
  </metadata>
  <metadata tag="submitter" timestamp="2007-03-26T20:27:32Z">
    falco
  </metadata>
  <metadata tag="bugReady" timestamp="2007-03-29T21:14:57Z">
    falco
  </metadata>
</glsa>