summaryrefslogtreecommitdiff
blob: b27acc47f04355cc8b407a6bd2f0d0b7c38ca893 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200711-07">
  <title>Python: User-assisted execution of arbitrary code</title>
  <synopsis>
    Multiple integer overflow vulnerabilities have been discovered in Python,
    possibly resulting in the execution of arbitrary code or a Denial of
    Service.
  </synopsis>
  <product type="ebuild">python</product>
  <announced>2007-11-07</announced>
  <revised>2007-11-07: 01</revised>
  <bug>192876</bug>
  <access>remote</access>
  <affected>
    <package name="dev-lang/python" auto="yes" arch="*">
      <unaffected range="rge">2.3.6-r3</unaffected>
      <unaffected range="ge">2.4.4-r6</unaffected>
      <vulnerable range="lt">2.4.4-r6</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Python is an interpreted, interactive, object-oriented programming
    language.
    </p>
  </background>
  <description>
    <p>
    Slythers Bro discovered multiple integer overflows in the imageop
    module, one of them in the tovideo() method, in various locations in
    files imageop.c, rbgimgmodule.c, and also in other files.
    </p>
  </description>
  <impact type="normal">
    <p>
    A remote attacker could entice a user to process specially crafted
    images with an application using the Python imageop module, resulting
    in the execution of arbitrary code with the privileges of the user
    running the application, or a Denial of Service. Note that this
    vulnerability may or may not be exploitable, depending on the
    application using the module.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All Python 2.3.x users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=dev-lang/python-2.3.6-r3"</code>
    <p>
    All Python 2.4.x users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=dev-lang/python-2.4.4-r6"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4965">CVE-2007-4965</uri>
  </references>
  <metadata tag="requester" timestamp="2007-10-27T13:38:30Z">
    rbu
  </metadata>
  <metadata tag="submitter" timestamp="2007-11-01T20:41:20Z">
    p-y
  </metadata>
  <metadata tag="bugReady" timestamp="2007-11-01T20:41:27Z">
    p-y
  </metadata>
</glsa>