summaryrefslogtreecommitdiff
blob: b062d045c6e1bbeddd308f5f4fadb67d5b3a32a9 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200712-08">
  <title>AMD64 x86 emulation Qt library: Multiple vulnerabilities</title>
  <synopsis>
    Multiple vulnerabilities in the AMD64 x86 emulation Qt library may lead to
    the remote execution of arbitrary code in Qt applications.
  </synopsis>
  <product type="ebuild">emul-linux-x86-qtlibs</product>
  <announced>2007-12-09</announced>
  <revised>2007-12-09: 01</revised>
  <bug>189536</bug>
  <access>remote</access>
  <affected>
    <package name="app-emulation/emul-linux-x86-qtlibs" auto="yes" arch="amd64">
      <unaffected range="ge">20071114-r2</unaffected>
      <vulnerable range="lt">20071114-r2</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Qt is a cross-platform GUI framework, which is used e.g. by KDE. The
    AMD64 x86 emulation Qt library packages Qt libraries for 32bit x86
    emulation on AMD64.
    </p>
  </background>
  <description>
    <p>
    The Qt versions used by the AMD64 x86 emulation Qt libraries were
    vulnerable to several flaws (GLSA 200708-16, GLSA 200710-28)
    </p>
  </description>
  <impact type="normal">
    <p>
    An attacker could trigger one of the vulnerabilities by causing a Qt
    application to parse specially crafted text or Unicode strings, which
    may lead to the execution of arbitrary code with the privileges of the
    user running the application.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All AMD64 x86 emulation Qt library users should upgrade to the latest
    version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=app-emulation/emul-linux-x86-qtlibs-20071114-r2"</code>
  </resolution>
  <references>
    <uri link="https://www.gentoo.org/security/en/glsa/glsa-200708-16.xml">GLSA 200708-16</uri>
    <uri link="https://www.gentoo.org/security/en/glsa/glsa-200710-28.xml">GLSA 200710-28</uri>
  </references>
  <metadata tag="requester" timestamp="2007-12-02T12:28:12Z">
    rbu
  </metadata>
  <metadata tag="submitter" timestamp="2007-12-09T19:55:14Z">
    welp
  </metadata>
  <metadata tag="bugReady" timestamp="2007-12-09T20:04:39Z">
    welp
  </metadata>
</glsa>