summaryrefslogtreecommitdiff
blob: 82877877f18f6af833b5dd43e55196aab6fdb728 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200805-17">
  <title>Perl: Execution of arbitrary code</title>
  <synopsis>
    A double free vulnerability was discovered in Perl, possibly resulting in
    the execution of arbitrary code and a Denial of Service.
  </synopsis>
  <product type="ebuild">perl libperl</product>
  <announced>2008-05-20</announced>
  <revised>2008-05-20: 01</revised>
  <bug>219203</bug>
  <access>remote</access>
  <affected>
    <package name="dev-lang/perl" auto="yes" arch="*">
      <unaffected range="ge">5.8.8-r5</unaffected>
      <vulnerable range="lt">5.8.8-r5</vulnerable>
    </package>
    <package name="sys-devel/libperl" auto="yes" arch="*">
      <unaffected range="ge">5.8.8-r2</unaffected>
      <vulnerable range="lt">5.8.8-r2</vulnerable>
    </package>
  </affected>
  <background>
    <p>
    Perl is a stable, cross platform programming language.
    </p>
  </background>
  <description>
    <p>
    Tavis Ormandy and Will Drewry of the Google Security Team have reported
    a double free vulnerability when processing a crafted regular
    expression containing UTF-8 characters.
    </p>
  </description>
  <impact type="normal">
    <p>
    A remote attacker could possibly exploit this vulnerability to execute
    arbitrary code or cause a Denial of Service.
    </p>
  </impact>
  <workaround>
    <p>
    There is no known workaround at this time.
    </p>
  </workaround>
  <resolution>
    <p>
    All Perl users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=dev-lang/perl-5.8.8-r5"</code>
    <p>
    All libperl users should upgrade to the latest version:
    </p>
    <code>
    # emerge --sync
    # emerge --ask --oneshot --verbose "&gt;=sys-devel/libperl-5.8.8-r2"</code>
  </resolution>
  <references>
    <uri link="https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1927">CVE-2008-1927</uri>
  </references>
  <metadata tag="requester" timestamp="2008-05-17T10:42:17Z">
    p-y
  </metadata>
  <metadata tag="bugReady" timestamp="2008-05-17T10:42:31Z">
    p-y
  </metadata>
  <metadata tag="submitter" timestamp="2008-05-17T13:52:28Z">
    keytoaster
  </metadata>
</glsa>